[Mono-osx] MonoDevelop and GTK

bmahf bmahf at hotmail.com
Sat May 1 18:26:18 EDT 2010

Hey Francisco, thanks for the reply.  I checked the MonoDevelop build output
and it is the following:

Building Solution FirstGladeProject

Building: FirstGladeProject (Debug|x86)
Performing main compilation...

/Library/Frameworks/Mono.framework/Versions/2.6.3/bin/gmcs /noconfig
/nologo /warn:4 /debug:+ /debug:full /optimize- /codepage:utf8 /platform:x86
"/define:DEBUG"  /t:winexe

Build complete -- 0 errors, 0 warnings

---------------------- Done ----------------------

Build successful.

No mention of a -resource option.  I right clicked the gui.glade file in my
solution browser and it the Build Action item showed that it was set to
"Embed as resource".  I changed that to "Resource" and again it gives the
same runtime error and the build output shows no -resource option.  

So then I went to Project -> <MyProject>Options -> Build -> Compiler, and
added the text "-resource:gui.glade", compiled and ran, and it worked just
fine.  Thanks for the help on that.

The only thing that remains is a question as to why, even though the
gui.glade file in the solution browser had been set (when right clicking and
choosing Build Action) to "Embed as resource", it wouldn't have just worked. 
And then my changing that option to "Resource" didn't make a difference. 
Why would I need to explicitly add the -resource option.  I am assuming that
this is a bug on the MacOS version of Mono.  What do you think?

Thanks again...

View this message in context: http://mono.1490590.n4.nabble.com/MonoDevelop-and-GTK-tp1548988p2122417.html
Sent from the Mono - OSX mailing list archive at Nabble.com.

More information about the Mono-osx mailing list