[Mono-osx] interop-ing problem with embedded mono

Phi Le iamphi at gmail.com
Wed Mar 24 16:03:21 EDT 2010


I have mono embedded in a cocoa application.  My app makes interops
call to a customized build of svn and I force the app to use the svn
libraries by setting DYLD_LIBRARY_PATH.   I am using the interops from
MonoDevelop - LibSvnClient:
.  This all works except when international characters are involved (I
have tested with Chinese, Japanese, Vietnamese).  I think the svn
libraries, specifically libapr, can't properly parse my
internationalized strings.

I built a test c# program that makes the same interop calls with
LibSvnClient and internationalized strings.  I run the program with
"DYLD_LIBRARY_PATH=<to custom svn libs> mono mytester.exe" and libapr
can parse the string, and everything works.

Can I get some help ?  I have tried messing with install names to
(install_name_tool) force the svn libs and mono to point to my copy of
libiconv but this didn't work.  libapr didn't let me change its
install name.

I have the problem on OS 10.5 and 10.6.



More information about the Mono-osx mailing list