[Mono-osx] [ANN] mcocoa 0.7 and mobjc 0.8

Jesse Jones jesjones at mindspring.com
Tue Jan 5 21:11:24 EST 2010

On Jan 5, 2010, at 2:48 PM, Lee V. Andrus wrote:

> I downloaded these and tried to build mobjc.  I got an error message
> indicating that something in the Mono framework was out of date.  I
> downloaded and installed the latest Mono framework and tried again.  I got
> this error message (which may be the same as the 1st):

I'm running mono 2.6.1 as well. I just downloaded mobj from the web site executed `make` and it built fine.
> [mono] /usr/local/source/mobjc- @ make
> gmcs -out:bin/tests.dll -checked+ -debug+ -warn:4 -warnaserror+ -d:DEBUG
> -d:TRACE -d:CONTRACTS_FULL -nowarn:1591	 -pkg:mono-nunit -r:bin/mobjc.dll
> -target:library test/*.cs

This is a little weird: it should have generated keys and built mobjc.dll before trying to build the tests.dll. I would try doing a `make distclean` and then `make` since you have re-installed mono.

> dyld: Library not loaded:
> /Library/Frameworks/Mono.framework/Versions/2.6.1/lib/libgthread-2.0.0.dylib
>  Referenced from:
> /Library/Frameworks/Mono.framework/Versions/2.6.1/bin/mono
>  Reason: Incompatible library version: mono requires version 2106.0.0 or
> later, but libgthread-2.0.0.dylib provides version 2001.0.0
> make: *** [bin/tests.dll] Trace/BPT trap
> It looks like the gthread library packaged with Mono is not new enough for
> the mono executable in the same framework.

I've never seen this and am not sure what to tell you if it persists, but it sounds like you were able to build the mobjc.dll at least once so maybe the problem is with nunit.

  -- Jesse

More information about the Mono-osx mailing list