[Mono-osx] MacOsX install

simon_domino simon_domino at yahoo.com
Fri Apr 2 01:00:04 EDT 2010

I'm having dramas installing Mono on a Mac. 

MacOs X : 10.5.8 PowerPC G5
Mono Runtime Version: 2.6.3

I downloaded the package installed. Seemed to work fine. 

First created a helloworld to test gtk as outlined on the getting started
Macintosh:~ admin$ mcs hellogtk.cs -pkg:gtk-sharp-2.0
error CS8027: Couldn't run pkg-config: ApplicationName='pkg-config',
CommandLine='--libs gtk-sharp-2.0', CurrentDirectory=''

so I created a link as recommended in one of the forum postings:
sudo ln -s /Library/Frameworks/Mono.framework/Commands/pkg-config

Tried to compile:
admin$ mcs hellogtk.cs -pkg:gtk-sharp-2.0

Then run:
mono hellogtk.exe

Unhandled Exception: System.DllNotFoundException: libgtk-quartz-2.0.0.dylib
  at (wrapper managed-to-native) Gtk.Application:gtk_init (int&,intptr&)
  at Gtk.Application.Init () [0x00000] in <filename unknown>:0 
  at Hello.Main () [0x00000] in <filename unknown>:0 

Also tried:
MonoDevelop failed to start. Some of the assemblies required to run
MonoDevelop (for example gtk-sharp, gnome-sharp or gtkhtml-sharp) may not be
properly installed in the GAC.
System.DllNotFoundException: libgtk-quartz-2.0.0.dylib
  at (wrapper managed-to-native) Gtk.Application:gtk_init (int&,intptr&)
  at Gtk.Application.do_init (System.String progname, System.String[]& args,
Boolean check) [0x00000] in <filename unknown>:0 
  at Gtk.Application.Init (System.String progname, System.String[]& args)
[0x00000] in <filename unknown>:0 
  at MonoDevelop.Ide.Gui.IdeStartup.Run (System.String[] args) [0x00000] in
<filename unknown>:0 
  at MonoDevelop.Startup.MonoDevelopMain.Main (System.String[] args)
[0x00000] in <filename unknown>:0 

A search on my system revealed the file is located here

Help would be appreciated :(

View this message in context: http://n4.nabble.com/MacOsX-install-tp1748832p1748832.html
Sent from the Mono - OSX mailing list archive at Nabble.com.

More information about the Mono-osx mailing list