[Mono-osx] Re questing tool attention for OS X

Chuck Esterbrook chuck.esterbrook at gmail.com
Sat Nov 28 13:23:40 EST 2009

Thanks for the comment.

I do have multiple Mono's installed with the current one pointing to
2.6. Seems like MonoDevelop should say "2.4 only" or "cannot have
multiple Monos" instead of "you don't have 2.4 or later".

Sorry if that sounds picky, but user experience is important too.

In /Library/Frameworks/Mono.framework/Versions, I have 2.4,
and 2.6. I "sudo rm -rf"ed 2.4 and still get the message. Then I
killed, with only 1 mono remaining, but still get the same
message. MonoDevelop 2.2 beta 2 says it wants or later but
what it really wants is >= and < 2.6.

Okay, so next I remove MonoDevelop 2.2 beta 2 and install the 2.0
version presented with Mono 2.6 preview 1. It launches, and creating a
Console application goes well. Next I create a Gnome# solution, but it
fails to compile because:

The type or namespace name `Gtk' could not be found. Are you missing a
using directive or an assembly reference?

However, I already tested that I can build and run a GTK# application
from the command line, so I'm not expecting such an error.

This experience is all kinds of FAIL.

(Btw I know the next step is to check for the GTK# reference in the solution.)


On Sat, Nov 28, 2009 at 9:56 AM, Stifu <stifu at free.fr> wrote:
> Hello,
> About MonoDevelop not working, telling you you don't have Mono 2.4 or later,
> this can happen if you have multiple versions of Mono installed. You could
> double check it's not the case.
> Chuck Esterbrook wrote:
>> Hi,
>> Poking around the web, I found "monodoc"
>> (http://www.mono-project.com/Monodoc), but it doesn't appear to be
>> available for Mac.
>> I saw someone reference "mdb" in IRC, but that's missing too.
>> There is also "mkbundle", which is present, but not working:
>> $ mkbundle -o hello hello.exe --deps
>> OS is: Darwin
>> Sources: 1 Auto-dependencies: True
>>    embedding: /Users/chuck/Scrap/dev/sharp/hello.exe
>>    embedding:
>> /Library/Frameworks/Mono.framework/Versions/
>> Compiling:
>> as -o temp.o temp.s
>> temp.s:2:unknown section type: symbol_stubs
>> temp.s:2:Rest of line ignored. 1st junk character valued 112 (p).
>> temp.s:3082:unknown section type: symbol_stubs
>> temp.s:3082:Rest of line ignored. 1st junk character valued 112 (p).
>> [Fail]
>> That's all on Mono on OS X 10.6.1.
>> I just installed Mono 2.6 preview 1 with no improvement.
>> Then I tried MonoDevelop for the first time. It won't launch because
>> it claims that I don't have Mono 2.4 or later (obviously I do). There
>> is a MonoDevelop preview download listed with the Mono 2.6 preview,
>> but it's MonoDevelop 2.0 instead of 2.2.
>> Mono works great for me on Mac in terms of compilers and non-GUI
>> libraries. But the other tools seem non-existant or broken.
>> Are there any insights from Mono project folks such as "get monodoc
>> here" or "change mkbundle options to this"?
>> If I need to fill out bug reports, let me know.
>> -Chuck
>> _______________________________________________
>> Mono-osx mailing list
>> Mono-osx at lists.ximian.com
>> http://lists.ximian.com/mailman/listinfo/mono-osx
> --
> View this message in context: http://old.nabble.com/Requesting-tool-attention-for-OS-X-tp26555333p26555390.html
> Sent from the Mono - OSX mailing list archive at Nabble.com.
> _______________________________________________
> Mono-osx mailing list
> Mono-osx at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-osx

More information about the Mono-osx mailing list