[Mono-osx] gac'ing assembly fails

slessard s_lessard at yahoo.com
Tue May 26 23:53:13 EDT 2009

Noobie question here...  I tried to GAC an assembly I downloaded from
Microsoft. gacutil failed saying the assembly is delay signed.  So I ran sn
to dump out the assembly's strong name info and got an error (see below.) 
What do I have to do to get this assembly installed in the GAC?

AppleJacks:Bin slessard$ gacutil -i Microsoft.Rtc.Collaboration.dll
Failure adding assembly Microsoft.Rtc.Collaboration.dll to the cache: Strong
name cannot be verified for delay-signed assembly

AppleJacks:Bin slessard$ sn -t Microsoft.Rtc.Collaboration.dll 
Mono StrongName - version
StrongName utility for signing assemblies
Copyright 2002, 2003 Motus Technologies. Copyright 2004-2008 Novell. BSD

ERROR: Unknown blob format.

View this message in context: http://www.nabble.com/gac%27ing-assembly-fails-tp23735573p23735573.html
Sent from the Mono - OSX mailing list archive at Nabble.com.

More information about the Mono-osx mailing list