[Mono-osx] Couldn't get CocoaSharp 0.9.4 to configure with Mono 2 (fixed?)

Catharz craigabread at gmail.com
Thu Jun 11 19:23:41 EDT 2009

neptune235 wrote:
> When running ./configure on the Cocoa Sharp src from the OS X download
> page (On Tiger) It would output the following error: 
> configure: error: You need to install mono >= 1.1.9
> But I had Mono 2 installed. So I searched the ./configure file for a the
> error text, and commented that whole block of code out.  It then
> configured without error, and both make and make install worked fine,
> though I haven't tried to use it yet. I will upload the modified configure
> script to this thread, but I need to switch over to my Mac...
> Okay, on my Mac now.  http://www.nabble.com/file/p21239429/configure.bak2
> configure.bak2  is now uploaded.

I'm getting the exact same problem with the latest version of Mono
(downloaded this morning) on my MacBook.

Looking at the code, there appears to be an "else" (line 20767) that doesn't
have an associated "if".
Is this the code you commented out?
View this message in context: http://www.nabble.com/Couldn%27t-get-CocoaSharp-0.9.4-to-configure-with-Mono-2-%28fixed-%29-tp21239429p23990608.html
Sent from the Mono - OSX mailing list archive at Nabble.com.

More information about the Mono-osx mailing list