[Mono-osx] ConfigurationErrorsException loading user settings (duplicate key)

d_v dan.vandermolen at figpsoft.com
Wed Jan 21 09:57:27 EST 2009

I experienced the same thing. Thanks for your solution!

I have had mixed results:
In two different test applications, with a web service reference, I seem to
be OK with both user and application configuration settings when creating a
new web service instance.

But my main application will fail, with a web service reference, if I have
mixed scopes when creating a new instance of the web service. It was still
an error even when I removed all other configuration settings.  But when I
changed the last remaining web service reference scope to "User" as you
suggested, it worked.  

zidjian wrote:
> A pitty that nobody replyed to my post, but maybe nobody had this problem
> before.
> Finally I found out a solution, but it took me many hours and some grey
> hairs.
> Looks like mono cannot handle applicationSettings but only userSettings.
> After setting all configuration entrys to userSetting mono worked fine.

View this message in context: http://www.nabble.com/ConfigurationErrorsException-loading-user-settings-%28duplicate-key%29-tp20559897p21584776.html
Sent from the Mono - OSX mailing list archive at Nabble.com.

More information about the Mono-osx mailing list