[Mono-osx] Help with Mono, IKVM -- sadly N00b-y

christopher hord chordam7 at yahoo.com
Wed May 21 16:05:12 EDT 2008


Thanks for your response. The symbolic link seemed like an excellent idea but still no luck. I created a symbolic link of the executable in /usr/bin/ and echoed the PATH to make certain it was on my PATH (it is). Still results in "command not found."

Also, tried navigating to the directory for the other tip and trying to invoke ikvm with "./ikvm" classname. Got error message, "No such file or directory."

Will keep trying, but I remain open to any feedback....


Andreas Färber <andreas.faerber at web.de> wrote: Christopher,

Am 21.05.2008 um 01:39 schrieb christopher hord:

> I get the response:
> /Library/Frameworks/Mono.framework/Versions/1.9.1/bin/ikvm
> /Library/Frameworks/Mono.framework/Versions/1.9.1/bin/ikvmc
> /Library/Frameworks/Mono.framework/Versions/1.9.1/bin/ikvmstub
> /Library/Frameworks/Mono.framework/Versions/1.9.1/lib/ikvm
> /Library/Frameworks/Mono.framework/Versions/1.9.1/lib/ikvm/ikvm- 
> native.dll
> /Library/Frameworks/Mono.framework/Versions/1.9.1/lib/ikvm/ikvm.exe
> /Library/Frameworks/Mono.framework/Versions/1.9.1/lib/ikvm/ikvmc.exe
> /Library/Frameworks/Mono.framework/Versions/1.9.1/lib/ikvm/ 
> ikvmstub.exe
> /Library/Frameworks/Mono.framework/Versions/1.9.1/lib/libikvm-native.a
> /Library/Frameworks/Mono.framework/Versions/1.9.1/lib/libikvm- 
> native.dylib
> /Library/Frameworks/Mono.framework/Versions/1.9.1/lib/libikvm- 
> native.la
> /Library/Frameworks/Mono.framework/Versions/1.9.1/lib/mono/ikvm
> /Library/Frameworks/Mono.framework/Versions/1.9.1/share/pkgconfig/ 
> ikvm.pc
> Encouraged by that, I decided maybe I was going about it wrong,  
> since ikvm might always expect a classname to follow. I whipped up a  
> quick "hello world", compiled a class and put that class into the  
> ikvm folder (so I knew everything should be found, because all the  
> files were in the same directory).

I can execute ikvm on 1.9.1_3 on Intel, the executable is symlinked  
in /usr/bin. You can execute it without arguments and get a help  
screen. You shouldn't need to put your files in any special folder.

Check whether there is such a symlink on your system ("ls -l /usr/bin/ 
ikvm") and whether /usr/bin is in your $PATH ("echo $PATH").

> I navigated to that directory and entered "ikvm" classname from the  
> terminal. Still got "-bash: ikvm: command not found...."

To execute it from the current directory you need to enter "./ikvm"  


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-osx/attachments/20080521/532da950/attachment.html 

More information about the Mono-osx mailing list