[Mono-osx] Using 1.9 for windows app.

Grant Crawford grantcrawford.inc at gmail.com
Wed May 7 00:33:19 EDT 2008

I downloaded Darwine and used TRIX to try and install the required  
packages. This is the output with this error:
	dyld: Symbol not found: _fnmatch$UNIX2003
	 Referenced from: /Applications/Darwine/TRiX.app/Contents/Resources/ 
  	 Expected in: /usr/lib/libSystem.B.dylib
I have no idea what it means, but will try and dig up some  
information on it.

The full output was:

	Welcome to Darwin!
	FigOne:~ grantcrawford$ curl http://www.kegel.com/wine/winetricks > / 
   	% Total    % Received % Xferd  Average Speed   Time    Time      
Time  Current
                                  Dload  Upload   Total   Spent     
Left  Speed
	100 47780  100 47780    0     0  18787      0  0:00:02  0:00:02  
--:--:-- 24282
	FigOne:~ grantcrawford$ export PATH=$PATH:"/Applications/Darwine/ 
	FigOne:~ grantcrawford$ sh /tmp/winetricks -q corefonts tahoma  
dotnet20 mono19
	Executing wget -nd -c --read-timeout=300 --retry-connrefused http:// 
	dyld: Symbol not found: _fnmatch$UNIX2003
   	Referenced from: /Applications/Darwine/TRiX.app/Contents/ 
   	Expected in: /usr/lib/libSystem.B.dylib

	/tmp/winetricks: line 1209: 11241 Trace/BPT trap          "$@"
	Note: command 'wget -nd -c --read-timeout=300 --retry-connrefused  
andale32.exe' returned status 133.  Aborting.
	FigOne:~ grantcrawford$

I don't know the scripting language (I am ex Windows), but this will  
be a good chance to find out.

thanks again Bobby.


On 06/05/2008, at 6:51 PM, Bobby Powers wrote:

> In fact, I just downloaded the latest Darwine build and it comes  
> with a mac gui for winetricks.
> On Tue, May 6, 2008 at 10:44 AM, Bobby Powers  
> <bobbypowers at gmail.com> wrote:
> On Tue, May 6, 2008 at 5:22 AM, Grant Crawford  
> <grantcrawford.inc at gmail.com> wrote:
> Bobby,
> Thanks for the response. I tried changing the directory as you  
> suggested, as well as the --debug. Both gave me the same result as  
> before, i.e., it reprinted the current directory on the next line;  
> eg.  FigOne:~/gcApplications/NinjaTrader/bin grantcrawford$
> I went back and ran Moma again, except this time I included all the  
> dll's that were in the ../NinjaTrader/bin/ folder( at first I  
> thought I only needed to include the NinjaTrader.Core.dll in Moma).  
> This time there were a lot (361) P/Invoke methods, mostly to  
> Gdi32.dll, user32.dll, and kernel32.dll. I guess I am hooped!
> Is there a way to use Mono and Wine together to cover both .NET  
> 2.0  and win32?
> I've had limited success with that on Linux, I haven't tried it on  
> OSX but it should be similar.  Your best bet is to download Darwine  
> from:
> http://www.kronenberg.org/darwine/
> and then downloading winetricks. you can use a browser or just the  
> counsole:
> wget http://www.kegel.com/wine/winetricks
> then, you can install .NET 2.0 by doing the following (in the same  
> directory you downloaded winetricks to):
> sh winetricks corefonts dotnet20
> if all goes right, this should install .NET 2.0 in wine.  Then you  
> should be able to open your application with:
> wine NinjaTrader.exe
> Theoretically that should work...
> yours,
> Bobby
> There is more info on winetricks here:
> http://wiki.winehq.org/winetricks
> thanks.
> Grant
> On 05/05/2008, at 9:31 PM, Bobby Powers wrote:
>> On Sat, May 3, 2008 at 10:01 AM, Grant Crawford  
>> <grantcrawford.inc at gmail.com> wrote:
>> I am new to mono and am trying to get a third third party windows  
>> application to run on my macbook pro (10.4.11).
>> I have installed mono 1.9.1 on my mac, and written a "hello world"  
>> C# console  application in windows to check that my mono  
>> installation is working. It works.
>> Then I checked if my third party software (NinjaTrader) with moma,  
>> and there were no issues mentioned. So I copied it across to my  
>> mac, with all the dll's that it requires,  and tried to run it  
>> from terminal with this command:
>> "mono /Users/grantcrawford/gcApplications/NinjaTrader/bin/ 
>> NinjaTrader.exe".
>> Absolutely nothing happened.  I am sure I must be doing something  
>> wrong. Is there a log I could look at to get some idea of what is  
>> happening? Do I have to have the source code to compile it myself  
>> with mono to get it to work?
>> what do you mean by nothing happened?  after you hit enter, did  
>> the cursor move down one line and sit at the beginning of a blank  
>> line or did it reprint something like "grantcrawford at localhost 
>> $" (the text that shows up when you open up a fresh terminal)?
>> try:
>> cd /Users/grantcrawford/gcApplications/NinjaTrader/bin
>> mono NinjaTrader.exe
>> Windows has a specific search path that it looks for DLLs in, and  
>> its possible that mono is checking your current directory (and not  
>> the NinjaTrader/bin folder) for some needed DLL.  Of course, if  
>> this were the case I would expect it to spit some error out...   
>> You can try
>> mono --debug NinjaTrader.exe
>> that might give you some more information.
>> best of luck!
>> Bobby
>> Excuse the simple question, but I am like a babe in the woods  
>> here, trying to move off windows to osx.
>> Grant
>> _______________________________________________
>> Mono-osx mailing list
>> Mono-osx at lists.ximian.com
>> http://lists.ximian.com/mailman/listinfo/mono-osx

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-osx/attachments/20080507/0e9e5bb4/attachment.html 

More information about the Mono-osx mailing list