[Mono-osx] Using 1.9 for windows app.

Grant Crawford grantcrawford.inc at gmail.com
Mon May 5 23:22:31 EDT 2008

Thanks for the response. I tried changing the directory as you  
suggested, as well as the --debug. Both gave me the same result as  
before, i.e., it reprinted the current directory on the next line;  
eg.  FigOne:~/gcApplications/NinjaTrader/bin grantcrawford$

I went back and ran Moma again, except this time I included all the  
dll's that were in the ../NinjaTrader/bin/ folder( at first I thought  
I only needed to include the NinjaTrader.Core.dll in Moma). This time  
there were a lot (361) P/Invoke methods, mostly to Gdi32.dll,  
user32.dll, and kernel32.dll. I guess I am hooped!

Is there a way to use Mono and Wine together to cover both .NET 2.0   
and win32?


On 05/05/2008, at 9:31 PM, Bobby Powers wrote:

> On Sat, May 3, 2008 at 10:01 AM, Grant Crawford  
> <grantcrawford.inc at gmail.com> wrote:
> I am new to mono and am trying to get a third third party windows  
> application to run on my macbook pro (10.4.11).
> I have installed mono 1.9.1 on my mac, and written a "hello world"  
> C# console  application in windows to check that my mono  
> installation is working. It works.
> Then I checked if my third party software (NinjaTrader) with moma,  
> and there were no issues mentioned. So I copied it across to my  
> mac, with all the dll's that it requires,  and tried to run it from  
> terminal with this command:
> "mono /Users/grantcrawford/gcApplications/NinjaTrader/bin/ 
> NinjaTrader.exe".
> Absolutely nothing happened.  I am sure I must be doing something  
> wrong. Is there a log I could look at to get some idea of what is  
> happening? Do I have to have the source code to compile it myself  
> with mono to get it to work?
> what do you mean by nothing happened?  after you hit enter, did the  
> cursor move down one line and sit at the beginning of a blank line  
> or did it reprint something like "grantcrawford at localhost$" (the  
> text that shows up when you open up a fresh terminal)?
> try:
> cd /Users/grantcrawford/gcApplications/NinjaTrader/bin
> mono NinjaTrader.exe
> Windows has a specific search path that it looks for DLLs in, and  
> its possible that mono is checking your current directory (and not  
> the NinjaTrader/bin folder) for some needed DLL.  Of course, if  
> this were the case I would expect it to spit some error out...  You  
> can try
> mono --debug NinjaTrader.exe
> that might give you some more information.
> best of luck!
> Bobby
> Excuse the simple question, but I am like a babe in the woods here,  
> trying to move off windows to osx.
> Grant
> _______________________________________________
> Mono-osx mailing list
> Mono-osx at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-osx

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-osx/attachments/20080506/f2f5cd82/attachment.html 

More information about the Mono-osx mailing list