[Mono-osx] Newbie Questions ....

Glen Warner gdwarner at mindspring.com
Tue Apr 22 10:37:50 EDT 2008


Okay, so I installed Mono Develop 1.5, which included the C# plugin.

Started Xcode, selected "New Project," and ... no C sharp.

Quit Xcode, and followed the instructions from the 02APR post on this 
page:  http://code.google.com/p/cocoa-sharp-dev/wiki/CSharpPlugin, which 
recommended moving the files to Developer/Library/XCode. Now when I 
start XCode and try to create a new project, I get an error:

"Internal Error

Uncaught Exception: - TSFileManager Support FilesRootPath?: selector not 
recognized [self=0x 352b90."

I am running 10.4.11 (Tiger) on a MacBook? Pro.

Any recommendations?

Also, went through the tough-to-follow instructions and put everything 
where it was supposed to be ... and still no joy.

Unfortunately, I don't quite recall where everything was ...!

Next question:

Went through the Simple Solution tutorial on the MonoDevelop page 
(http://www.monodevelop.com/Creating_A_Simple_Solution) and got all the 
way to Step 2 before I ran into trouble.  The trouble?

The part of the step that reads as follows:

"To do this, right click on the Solution icon in the Solution Pad. 
Select 'Add->Add New Project'."

As I don't have a two button mouse on my MacBook Pro, I did what I 
normally do in those situations and held down the ctrl (control) key as 
I clicked ... but still, no contextual menu came up.

Needless to say, can't get through the tutorial that way, since 
subsequent steps require the occasional right-click!

Any way to fix that for the next version?

As you might guess, with these two *major* problems, I can't do much of 
anything C#-wise with either Xcode and the CSharp Plugin or MonoDevelop.

Finally, I hope this is the right place to post these questions.  I 
posted the CSharp Plugin issue on the Google page, just before it "went 
down for maintenance" and became read-only (timing truly is everything!).


More information about the Mono-osx mailing list