[Mono-osx] Problems using Tao Framework

Bart Masschelein masschel at gmail.com
Sun Sep 30 08:49:19 EDT 2007

Hi all,

I'm trying to use the Tao Framework on mono 1.2.5 for osx. I'm using  
the latest from svn, as this one does not give problems when using  
the build scripts. Everything goes fine, until I want to run the  
examples. For the CG examples I get

  System.DllNotFoundException: /System/Library/Frameworks/ 

and for the SDL examples I get similar error messages. I'm sure I  
have both frameworks installed, and at the indicated location. It's  
true however, that these directories don't contain .dylib files. I've  
read in another post that the PATHor LD_LIBRARY_PATH environment  
variable should be set correctly, but where are the libraries the  
actually located? Anyway, a previous post (http:// 
cjcollier.livejournal.com/122002.html) shows that nothing more should  
be done, and it should be automagically done.

I also tried to use the darwin port glut, and changing my .config  
file accordingly, but with the same error (for glut then of course).

Anyone got lucky on this issue, and could shed some light here?



More information about the Mono-osx mailing list