[Mono-osx] getting shm_semaphore errors with mono 1.2.5_5 on MacOSX 10.4.10, Intel

Jason Rosenberg jasonrosenberg at charter.net
Thu Sep 13 09:30:32 EDT 2007


I'd like to run signcode.exe on a mac.  I installed the macos version of 
mono, version 1.2.5_5.  When I run the signcode included with the mono 
install, I get the following error:

** ERROR **: shm_semaphores_init: semget error: No space left on 
device.  Try deleting some semaphores with ipcs and ipcrm
or increase the maximum number of semaphore in the system.

I get the same error when I try to run mono with my own version of 
signcode.exe.  I have been able to run this ok using the same version of 
signcode.exe on linux, using mono 1.2.4.

There aren't any looked semaphores displayed when I run ipcs, etc....

I googled around a bit, appears there's a known problem with this on 
linux previously, starting from or so, is that right?

I uninstalled mono, using the remove script listed here:  

I downloaded a couple older version of mono for mac, e.g. and 
1.2.4, to try those, and the installer won't even allow me to install, 
saying a newer version is already installed, and there's nothing to install.

Anyone have any ideas?

My machine is running MacOSX 10.4.10, with an Intel processor.



More information about the Mono-osx mailing list