[Mono-osx] An open letter to the OS X Mono group.

Hawston LLH hawston at gmail.com
Wed Apr 11 00:07:35 EDT 2007

I have problem at getting Dumbarton compiled, the subproject Judy
compilation is ok. I have 'chmod 700 configure' and 'xcodebuild' at command
line for Dumbarton source, it still fail. I have set the Judy and Dumbarton
build into same folder. The error given is

ld: /Volumes/Data/Mono/src/build/Debug/libJudy.a(JudyLTables.o) r_address
(0xeb4c) field of relocation entry 14 in section (__DWARFA,__debug_info) out
of range /usr/bin/libtool: internal link edit command failed

If I compile the Dumbarton in xcode, the linking error is:

table of contents for archive:
/Volumes/Data/Mono/src/build/Release/libJudy.a is out of date; rerun
ranlib(1) (can't load from it)

I tried 'ranlib libjudy.a' in terminal, still no use. please help.

On 4/11/07, Miguel de Icaza <miguel at novell.com> wrote:
> > Could this be a runtime option controlled via environment variable
> > rather than build time?
> yes, as documented in the man page.
> _______________________________________________
> Mono-osx mailing list
> Mono-osx at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-osx
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-osx/attachments/20070411/d9c6837a/attachment.html 

More information about the Mono-osx mailing list