[Mono-osx] Active Directory Infinite Loop

Jaume Llardén Prieto jllarden at aim.com
Thu Apr 5 02:17:43 EDT 2007


There's a workaround: define the UID and GID in Directory Access.

The whole process is:
Open Directory Access in Applications/Utilities, select Active  
Directory in panel Services and press Configure. In the Advanced  
Options, choose tab Mappings and choose a mapping. For my test I  
chose UID to map to postalCode, UGID to primaryGroupID and GGID again  
to postalCode (I needed a numeric attribute to play with and  
postalCode was good enough). Then bind and you're done.

I chose low values: uid=4055, ugid=513 and ggid=4055. And my  
'test.exe' worked. Without this workaround I suffered the described  

The catch is that you have to change the uid/gid of the home  
directories of the affected users locally on every Mac.

Kind regards

On 4 Apr 2007, at 17:11, Daniel Abrams wrote:

> uid=435092441
> gid=1309106314
> On 4/4/07, Eoin Norris <e.norris at mac.com> wrote:
> If you are running on an active directory account what is your gid  
> and uid - the result of ( as you prob. know) typing id in the  
> terminal?
> -- Eoin
> On 4 Apr 2007, at 15:57, Daniel Abrams wrote:
>> On 4/4/07, Eoin Norris < e.norris at mac.com> wrote:
>> Well, my application is generally home-based but I would kinda think
>> 15% of all users high, though it may be 15% of all macs deployed
>> across  "schools, colleges, companies, government" but whatever about
>> schools macs in the enterprise are extremely rare. So the total of
>> all macs is lower.
>> Perhaps.  I worked for Apple in what was the Enterprise and  
>> Education divisions, and I think my numbers are pretty  
>> conservative, but maybe the ratio has shrunk.  I can tell you that  
>> one of my current clients is a large government agency, and macs  
>> are not as rare as you might think, and they all use active  
>> directory authentication.
>> It is an issue for deployment as well. I am getting reports in the
>> field. I dont know specifically where to look in the Mono code
>> ( where it is happening) but the thread below ( taken from this list)
>> gives some examples. The original poster does not seem to be on the
>> list anymore, or not contributing to this new thread on the same
>> issue, but might be available on that email address.
>> http://lists.ximian.com/pipermail/mono-osx/2006-January/000444.html
>> He clearly did some research and ascertained that it was an Apple  
>> bug.
>> I can't say if its an Apple bug or not.  I could certainly believe  
>> that POSIX threads are done differently in Mac OS X than in Linux,  
>> and that the Apple implementation is incomplete or buggy, I don't  
>> have much experience in that area.  But I do know that in higher  
>> level environments, Java, ObjC, etc, thread and process management  
>> work fine on OS X and that many other development and deployment  
>> environments have managed to solve threading issues without dying  
>> early on Mac OS X.  Unless it's solved, it effectively rules out  
>> Mono development for us, but I understand that your mileage may vary.
> _______________________________________________
> Mono-osx mailing list
> Mono-osx at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-osx

More information about the Mono-osx mailing list