[Mono-osx] My Project Files Moved & Susan's Xcode Plug-in

Susan Mackay susanmackay at optusnet.com.au
Fri Oct 20 06:24:44 EDT 2006

OK, I've just installed Mono 1.1.18 from the
MonoFramework01.1.18_0.macos10.novell.x86.dmg image and I get the same
behaviour as you. I've tried to have the output go to the console log and I
get the same error message and stack trace. Also, like you, the built
application works from the terminal.

That's with an Intel-based system. So the same error occurs in Intel and PPC
which makes me think that the error is NOT platform-specific.

I must admit that I can't for the life of me think of any reason why there
should be any difference between 1.1.17 and 1.1.18 *UNLESS* something has
changed within the Mono runtime.

Xcode uses one of the 'unix'-style system calls to spawn off the executable
(hence the separation of the command and the arguments) and I have no idea
what it tells the spawned subprocess is the 'stdout' device. However, going
by the stack trace, Mono doesn't like whatever it is.

My guess is that something has broken in the Mono runtime - I note that
1.1.18 has a "updated console driver":



Update the Console to better track the state of the screen, but it still is
known to contain a few bugs, the console is also hooked up to some internal
streams (to allow users that were manipulating the streams directly to use
it) [Gonzalo Paniagua].

The updated Console will no longer throw an exception if its output is


That last statement may need to be reviewed!!!!!



More information about the Mono-osx mailing list