[Mono-osx] Building mono-1.1.18 20061018

Diane Trout diane at ghic.org
Wed Oct 18 17:22:47 EDT 2006


I was trying to build mono 1.1.18 and then 1.1.18 20061018 on a  
macbook pro, but the build kept hanging. It appeared that the  
bootstrapped mono binary wouldn't terminate. It required a kill -9 to  
stop it.

I tried a bootstrap build after deleting the links in /usr/bin  
installed by the framework installation of mono. Then I,  
unsuccessfully as far as I can tell, tried setting EXTERNAL_MCS and  
EXTERNAL_MONO to point to the contents of Mono.framework.

FInally I just copied the mono out of /Library/Frameworks/ 
Mono.framework/Commands on top of mono-1.1.18/mono/mini/mono which at  
least allowed my build to finish.

Has anyone else had this problem bootstrapping or any suggestions  
about what's going wrong?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: This is a digitally signed message part
Url : http://lists.ximian.com/pipermail/mono-osx/attachments/20061018/92d8e3ee/attachment.bin 

More information about the Mono-osx mailing list