[Mono-osx] Builds are failing due to ~ranlib missing?

Sean Hignett seanhig at geminibay.com
Wed Mar 22 11:06:25 EST 2006

Thanks for the help GJ,

That was a pointer in the right direction...

I had installed a new automake (1.9.6) to /usr/local, but the old 1.6.3 was
installed in /usr (default from apple).

I cleaned up all my paths, but for some reason when I ran autogen.sh it
would create bad Makefiles.  As an experiment (and learning) I walked
through the autogen.sh steps manually and ran each step by hand using what I
believed would be the right arguments based on the script.

And just to confuse things further this worked... Built, installed and

I don't have MONO_PATH set, which is what you would think would mess things
up given the script.

The ~ranlib was a side effect of an aclocal version issue I think... But all
I have are the WAGs of a newbie to explain it.

The joyous learning curve of jumping into the deep end.

Thanks again... Few take the time to help the truly ignorant :)

On 3/21/06 1:28 AM, "Baker, GJ (Gareth)" <g.j.baker at dl.ac.uk> wrote:

> Not quite sure what would cause it - but it looks like a "end of line"
> issue in the Makefile. Where the "~" is should be a line break with
> "ranlib .libs/libmonoutils.a" being a separate command.
> Regards
> Gareth Baker
> -----Original Message-----
> From: mono-osx-bounces at lists.ximian.com
> [mailto:mono-osx-bounces at lists.ximian.com] On Behalf Of Sean Hignett
> Sent: 20 March 2006 22:15
> To: mono-osx at lists.ximian.com
> Subject: [Mono-osx] Builds are failing due to ~ranlib missing?
> Last few days the builds I am pulling from Anon SVN are kacking:
> I am a newbie, can anyone help me with a pointer?  I am on a macbook
> pro.
> I can build the pull from March 18th no problem.
> Thanks.
> Sean
> (error below)
> gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I../../mono
> -I../../libgc/include -pthreads -I/usr/local/include/glib-2.0
> -I/usr/local/lib/glib-2.0/include -I/usr/local/include/glib-2.0
> -I/usr/local/lib/glib-2.0/include -no-cpp-precomp -D_THREAD_SAFE
> -DGC_MACOSX_THREADS -DPLATFORM_MACOSX -g -O2 -fno-strict-aliasing -g
> -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations
> -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs
> -Wpointer-arith -Wno-cast-qual -Wcast-align -Wwrite-strings -MT
> mono-poll.lo -MD -MP -MF .deps/mono-poll.Tpo -c mono-poll.c -o
> mono-poll.o >/dev/null 2>&1 /bin/sh ../../libtool --tag=CC --mode=link
> gcc  -g -O2 -fno-strict-aliasing -g -Wall -Wunused -Wmissing-prototypes
> -Wmissing-declarations -Wstrict-prototypes  -Wmissing-prototypes
> -Wnested-externs -Wpointer-arith -Wno-cast-qual -Wcast-align
> -Wwrite-strings  -pthread -o libmonoutils.la mono-hash.lo mono-md5.lo
> mono-sha1.lo mono-logger.lo mono-codeman.lo mono-counters.lo
> monobitset.lo mono-math.lo strtod.lo strenc.lo mono-uri.lo mono-poll.lo
> -lpthread -lm ar cru .libs/libmonoutils.a .libs/mono-hash.o
> .libs/mono-md5.o .libs/mono-sha1.o .libs/mono-logger.o
> .libs/mono-codeman.o .libs/mono-counters.o .libs/monobitset.o
> .libs/mono-math.o .libs/strtod.o .libs/strenc.o .libs/mono-uri.o
> .libs/mono-poll.o~ranlib .libs/libmonoutils.a
> ar: .libs/mono-poll.o~ranlib: No such file or directory
> make[3]: *** [libmonoutils.la] Error 1
> make[2]: *** [all-recursive] Error 1
> make[1]: *** [all-recursive] Error 1
> make: *** [all] Error 2
> _______________________________________________
> Mono-osx mailing list
> Mono-osx at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-osx

More information about the Mono-osx mailing list