[Mono-osx] Mono and Active Directory?!

Rick Schaut rsschaut at hotmail.com
Sat Jan 28 19:36:37 EST 2006

I'm not sure if this issue is confined to Mac OS X or not, but the Mono
runtimes fall into an infinite loop when trying to execute any cli program
(including mcs.exe).  The issue appears to be confined to accounts where the
user logs in using Active Directory credentials.

The infinite loop involves successive "access denied" failures on semget and
semctl.  While the loop is executing, I get the following error messages in
the terminal window:

41): WARNING **:_wapi_shm_semaphores_init: semget error: Permission denied
key 0x4d09fd6d - trying again

41): WARNING **:_wapi_shm_semaphores_init: semctl init error: Permission
denied - trying again

In successive iterations through the loop, the ³key² in the first error
message increases by one from the previous pair of error messages.

The problem did not appear in build 1.6.1, and did appear in 1.8.1 or later

Having not looked at the code, I have no idea why this happens.  Note that
it does not happen when I log in as a local user.  I¹ve tried with admin
privileges on the AD user account, and still no go.

The problem occurs on two different machines, though I¹m using the same
Active Directory account.  The machines are both G4 PowerBooks, one running
10.3.9 and the other running 10.4.4.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-osx/attachments/20060128/b31844b8/attachment.html

More information about the Mono-osx mailing list