[Mono-osx] Problem running VB.NET app with

Joshua Kugler joshua.kugler at uaf.edu
Tue Feb 7 21:53:01 EST 2006

Just to preface: I don't think this is related to Windows.Forms, as I did read 
through a few messages about those on the list archive.

Tonight I downloaded version from the /Download section and installed 
them on my Linux machine and a Mac machine.

I took a simple app I had written and compiled and tried to run them on the 
Linux box and Mac box.

On the Linux box, it ran flawlessly.  Woohoo!

My first try on the Mac box complained about something not implemented.  
Starting the X server solved that.

Then, I tried it again.  It displays the app, along with all visible buttons, 
but then it crashes, with this in the console:

cdesysadminmac:~/Desktop joshua$ mono WindowsApplication1.exe 
Mono System.Windows.Forms Assembly [Revision: 54007; built: 2005/12/6 
Keyboard: United States keyboard layout
Gtk not found (missing LD_LIBRARY_PATH to libgtk-x11-2.0.so?), using built-in 

Unhandled Exception: System.TypeInitializationException: An exception was 
thrown by the type initializer for Mono.Unix.Native.Syscall ---> 
System.DllNotFoundException: libMonoPosixHelper.dylib
in (wrapper managed-to-native) Mono.Unix.Native.Syscall:_L_ctermid ()
in <0x00090> Mono.Unix.Native.Syscall:.cctor ()--- End of inner exception 
stack trace ---

in <0x00000> <unknown method>
in <0x00238> System.Windows.Forms.XplatUIX11:UpdateMessageQueue ()
in <0x00234> System.Windows.Forms.XplatUIX11:UpdateMessageQueue ()
in <0x001b8> System.Windows.Forms.XplatUIX11:GetMessage 
(System.Windows.Forms.MSG msg, IntPtr handle, Int32 wFilterMin, Int32 
in <0x00058> System.Windows.Forms.XplatUI:GetMessage (System.Windows.Forms.MSG 
msg, IntPtr hWnd, Int32 wFilterMin, Int32 wFilterMax)
in <0x00858> System.Windows.Forms.Application:RunLoop (Boolean Modal, 
System.Windows.Forms.ApplicationContext context)
in <0x00034> System.Windows.Forms.Application:Run (System.Windows.Forms.Form 
in <0x00034> WindowsApplication1.Form1:Main ()

I checked for libMonoPosixHelper.dylib, and it is 
in /Libraries/Frameworks/Mon.framework/Libraries

I didn't see anything in the install notes.  Is there some post-install step I 
missed or that is not documented?

Thanks!  I look forward to using Mono to make a cross platform App here at 

j----- k-----

Joshua Kugler                 PGP Key: http://pgp.mit.edu/
CDE System Administrator             ID 0xDB26D7CE

More information about the Mono-osx mailing list