[Mono-osx] Re: Mono 1.1.10 + MacOS

Baker, GJ (Gareth) g.j.baker at dl.ac.uk
Sat Nov 19 12:11:01 EST 2005

The Mono 1.1.10 package I downloaded did have Cocoa# in, I had to install it manually.

The SVN compiles OK from source and cocoa# programs then work OK.

Still no joy with any native OSX windows.forms programs (and some problems with X11 windows.forms!!)

Gareth Baker

-----Original Message-----
From: mono-osx-bounces at lists.ximian.com on behalf of Edward J. Sabol
Sent: Sat 11/19/2005 1:39 AM
To: mono-osx at lists.ximian.com
Subject: [Mono-osx] Re: Mono 1.1.10 + MacOS
> I downloaded the latest release and then attempted to test my program,
> which uses Windows Forms, but it does not work! It starts to launch and
> then it simply exits. This same code would compile and run under 1.1.9,
> but some of the Windows controls did not work as well as they should.

My experience is similar to yours. A Windows.Forms application that mostly
worked in a previous version of Mono now doesn't work at all with Mono

> As I mentioned, when I double-click on DoubleElimination.app, the icon
> appears in the dock, bounces three times and then disappears!

Check your console.log using the Console application in
/Applications/Utilities. It should give you more information. I'm willing to
bet your program is dying with an unimplemented function exception.

I filed a bug report about an unimplemented function exception for
DefineCursor, but it was closed and I was basically told not to file bug
reports for Mac OS X problems since the Mac is not a priority for the Mono WF

However, seeing that there have been several other people reporting problems
with Mono 1.1.10, I'm starting to think that it's possible Mono 1.1.10 for
the Mac was just packaged wrong. (It's happened before!)

Has *anyone* gotten a Windows Forms or Cocoa# application to work with Mono
Mono-osx mailing list
Mono-osx at lists.ximian.com

More information about the Mono-osx mailing list