[Mono-osx] Solved.

Armin Arnegger armin.arnegger at mac.com
Sat May 21 18:46:39 EDT 2005

Hi all

If I ran a simple Winforms Sample:
using System;
using System.Windows.Forms;

public class WinFormsHello
	public static void Main ()
		MessageBox.Show("Hello WinForms on Mac OS X");

I get the Errors:
Mono System.Windows.Forms Assembly [Revision: 41731; built: 2005/2/15 

Unhandled Exception: System.EntryPointNotFoundException: 
in (wrapper managed-to-native) 
in <0x00084> System.Drawing.Graphics:FromHwnd (IntPtr hwnd)
in <0x00070> System.Windows.Forms.XplatUIOSX:PaintEventStart (IntPtr 
in <0x00034> System.Windows.Forms.XplatUI:PaintEventStart (IntPtr 
in <0x001e8> System.Windows.Forms.Control:WndProc 
(System.Windows.Forms.Message m)
in <0x000b4> System.Windows.Forms.ButtonBase:WndProc 
(System.Windows.Forms.Message m)
in <0x0001c> System.Windows.Forms.Button:WndProc 
(System.Windows.Forms.Message m)
in <0x00034> System.Windows.Forms.Control+ControlNativeWindow:WndProc 
(System.Windows.Forms.Message m)
in <0x001b0> System.Windows.Forms.NativeWindow:WndProc (IntPtr hWnd, 
Msg msg, IntPtr wParam, IntPtr lParam)
in <0x00028> System.Windows.Forms.XplatUIOSX:DispatchMessage 
(System.Windows.Forms.MSG msg)
in <0x00034> System.Windows.Forms.XplatUI:DispatchMessage 
(System.Windows.Forms.MSG msg)
in <0x009a0> System.Windows.Forms.Application:ModalRun 
(System.Windows.Forms.Form form)
in <0x000c8> System.Windows.Forms.Form:ShowDialog (IWin32Window 
in (wrapper remoting-invoke-with-check) 
in <0x00020> System.Windows.Forms.Form:ShowDialog ()
in (wrapper remoting-invoke-with-check) 
System.Windows.Forms.Form:ShowDialog ()
in <0x00050> System.Windows.Forms.MessageBox+MessageBoxForm:RunDialog ()
in (wrapper remoting-invoke-with-check) MessageBoxForm:RunDialog ()
in <0x00068> System.Windows.Forms.MessageBox:Show (System.String text)
in <0x00014> WinFormsHello:Main ()

The same sample works fine with 1.1.6-4 and 1.1.7.
My Cocoa Samples works well.

Thanks for help


Am 21.05.2005 um 17:24 schrieb Miguel de Icaza:

> Hey,
>    Oh, so the problem is that the script was packaging some older
> versions in the BUILDROOT, not necessarily pulling stuff from
> the /Library/Frameworks/Mono.framework directory.
>    I have uploaded the new package here, please test and comment:
> http://primates.ximian.com/~miguel/tmp/MonoFramework-
>    The md5sum is:
> ef82b0a4f4e0cda87f267c07e9933d25  MonoFramework-
>    This one is a 28 meg download and included Cocoa#.
> Miguel.
> _______________________________________________
> Mono-osx mailing list
> Mono-osx at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-osx
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: text/enriched
Size: 3225 bytes
Desc: not available
Url : http://galactus.ximian.com/pipermail/mono-osx/attachments/20050522/6561ad88/attachment.bin

More information about the Mono-osx mailing list