[Mono-list] Nuget Alpine - trust errors

David Curylo curylod at asme.org
Tue Jun 20 01:28:45 UTC 2017

This seemed to do the trick:

cat /etc/ssl/cert/*.pem > /tmp/ca-certs.pem
cert-sync /tmp/ca-certs.pem
rm /tmp/ca-certs.pem

I’m not sure if there is some other order of operations that would have worked better, like maybe installing ca-certificates before mono, but I’m glad for cert-sync.


> On Jun 19, 2017, at 7:00 PM, Martin Thwaites <monoforum at my2cents.co.uk> wrote:
> Have you tried using Mozroots... not sure if that's still the thing to use to import all the certificates...
> On 19 June 2017 at 22:41, David Curylo <curylod at asme.org <mailto:curylod at asme.org>> wrote:
> Hey everyone, I’m reaching out for some help with mono 5.0.1 on Alpine.
> I’m attempting to use nuget on Alpine to install a package, but I’m hitting trust issues.
> I downloaded nuget.exe with `wget https://nuget.org/nuget.exe` <https://nuget.org/nuget.exe%60> after I installed ca-certificates and openssl, but this doesn’t seem to be enough to satisfy nuget itself.  Any tips?  This is the error I get, but I can’t seem to get around it.
> Error: TrustFailure (Ssl error:1000007d:SSL routines:OPENSSL_internal:CERTIFICATE_VERIFY_FAILED
>   at /home/buildozer/aports/testing/mono/src/mono-
> Thanks,
> Dave
> _______________________________________________
> Mono-list maillist  -  Mono-list at lists.dot.net <mailto:Mono-list at lists.dot.net>
> http://lists.dot.net/mailman/listinfo/mono-list <http://lists.dot.net/mailman/listinfo/mono-list>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.dot.net/pipermail/mono-list/attachments/20170619/d189c903/attachment.html>

More information about the Mono-list mailing list