[Mono-list] Assertion error on Pogoplug

lukamicoder lukamicoder at gmail.com
Fri Jul 15 10:22:35 UTC 2016

I installed Mono on a Pogoplug, an ARM5 device running Debian Jessie, based
on the instructions of this page:


It looks like it got installed just fine, when I run 'mono -V' this is
what's printed:

Mono JIT compiler version 4.4.1 (Nightly Wed Jun 22 11:40:56
UTC 2016)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors.
	TLS:           __thread
	SIGSEGV:       normal
	Notifications: epoll
	Architecture:  armel,vfp+fallback
	Disabled:      none
	Misc:          softdebug 
	LLVM:          supported, not enabled.
	GC:            sgen

However, when I run a simple Hello World application (or any application for
that matter) I get this error:
* Assertion at unwind.c:385, condition `read16 (p) == (guint32)(op->when -
loc)' not met

Any idea what causes this error and how to prevent it?

View this message in context: http://mono.1490590.n4.nabble.com/Assertion-error-on-Pogoplug-tp4668167.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list