[Mono-list] Mono throws "OutOfMemoryException" on Linux but Visual Studio does not on Windows

Mohamadsoltani soltani at ualberta.ca
Thu Oct 1 19:34:54 UTC 2015

Hi all,

I need to run my C#-based code on a server with Linux. I am using Visual
Studio on my pc, but now I should switch to mono on the server.
I have tried to test my code by running a single job with mono. But there is
a strange problem. When I run my code by directly using Visual Studio on my
pc, everything is working well. Surprisingly, when I try the same thing on
Linux, an "OutOfMemoryException" happens when the code is in a line to
generate an array. The size of this array is (6,156 * 24,624), which is
totally fine! I have arrays with similar size earlier in my code, and there
is no "OutOfMemoryException" for them.

I would be grateful if anyone can help me to understand what is the main
reason for this issue and how can I handle it?

View this message in context: http://mono.1490590.n4.nabble.com/Mono-throws-OutOfMemoryException-on-Linux-but-Visual-Studio-does-not-on-Windows-tp4666669.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list