[Mono-list] Missing "Unix" inside of "Mono"

Timotheus Pokorra timotheus.pokorra at solidcharity.com
Wed May 20 13:08:25 UTC 2015

Hello Baltasar,

I have fired up a Ubuntu 14.04 machine, with Xamarin mono packages.
locate Mono.Posix

dpkg-query -S /usr/lib/mono/gac/Mono.Posix
libmono-posix4.0-cil: /usr/lib/mono/gac/Mono.Posix

So if you install apt-get install libmono-posix4.0-cil from the
Xamarin repo, and you run the sed commands on your extracted pinta
tarball (https://github.com/PintaProject/Pinta/releases/download/1.6/pinta-1.6.tar.gz):

find . -name "*.sln" -print -exec sed -i 's/Format Version
10.00/Format Version 11.00/g' {} \;
find . \( -name "*.csproj" -o -name "*.proj" \) -print -exec sed -i
s#Mono.Posix, Version.*"#Mono.Posix"#g' {} \;

then you should be able to run configure and make.

I only referenced the git of Pinta in Fedora, because of these lines
in the spec file.

Hope this helps,

On 20 May 2015 at 14:53, Baltasar García Perez-Schofield
<baltasarq at gmail.com> wrote:
> Hi,
>> Have a look at how we solved the problem for Fedora, to build pinta with
>> Mono4:
>> http://pkgs.fedoraproject.org/cgit/pinta.git/
> Sorry, but don't know how to make heads and tails of this. Also, the issue
> is a missing dll... can this be solved by fixing the sources?
> -- baltasar

in Plauen: 03741 7424995

More information about the Mono-list mailing list