[Mono-list] 503 error

Agustin Gimenez geniwab at gmail.com
Thu Jul 2 16:34:37 UTC 2015


This is not really a solution to your problem but can help you if you are
out of luck and need a workaround.

I had a lot of troubles with mod_mono in some systems (CentOS mostly) but
in others it works really well (Debian as an example), so, I needed a
solution which worked out of the box in any system and did this:

1-Create your own ASP .net server using an HttpListener, it's easy, here
you have a very reduced example:
2-Install an nginx as reverse proxy and let it decode the HTTPS requests so
it forwards to your server plain HTTP requests

Point 2 is very important because httplistener in mono has a ton of
troubles with SSL, using nginx as reverse proxy and HTTPS decoder removes
all those problems

I have this solution in multiple servers and it works very well (right, my
asp server is a "bit" more advanced but the base is the same).


2015-07-02 16:06 GMT+02:00 Wayne Douglas <wayne at made-software.com>:

> FYI servicestack works great on *Nix  https://servicestack.net/
> :)
> On Thu, Jul 2, 2015 at 2:54 PM, Timotheus Pokorra <
> timotheus.pokorra at solidcharity.com> wrote:
>> > httpd -M shows that mono is running but the result is the same. Is
>> there a
>> > way to determine if xsp is running? Is there a way to make sure that
>> mono is
>> > calling xsp4 and not xsp? Either of those would result in the 'Failed to
>> > connect to mod-mono-server after several attempts to spawn the
>> process.' I
>> > would think. I still have no answer for the '[ERROR] FATAL UNHANDLED
>> > EXCEPTION: System.InvalidProgramException: Invalid IL code in
>> > System.Configuration.ConfigurationManager:get_AppSettings (): IL_0000:
>> ret'
>> > though. I hope that they are tied together.
>> First try the whole thing without httpd. Just start xsp4 in the
>> directory where your web.config and your aspx files are.
>> If that works, then the next step would to get it to work with mod_mono.
>> I have never tried mod_mono, but use fastcgi-mono-server4 instead.
>> Perhaps my configuration can give you some ideas:
>> https://github.com/openpetra/openpetra/blob/master/setup/petra0300/linuxserver/postgresql/centos/openpetra-server.sh
>> Timotheus
>> _______________________________________________
>> Mono-list maillist  -  Mono-list at lists.ximian.com
>> http://lists.ximian.com/mailman/listinfo/mono-list
> _______________________________________________
> Mono-list maillist  -  Mono-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-list
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-list/attachments/20150702/7764a519/attachment.html>

More information about the Mono-list mailing list