[Mono-list] Sharpen errors

Dimitar Dobrev dpldobrev at yahoo.com
Sun May 18 15:18:58 UTC 2014

Hi all,

I've been trying to use  Sharpen <https://github.com/slluis/sharpen>   to
convert  https://github.com/koush/UrlImageViewHelper
<https://github.com/koush/UrlImageViewHelper>   to C# (the version at 
<https://github.com/Redth/MonoDroid.UrlImageViewHelper>   is more than a
year old). Unfortunately, I cannot get it to work:

1. I tried using the pre-built copy at 
and after configuring everything I get to "Syntax error, annotations are
only available if source level is 1.5 or greater" for @Override-s. My
Eclipse has 1.6 settings for the Java Compiler (including classes
compliance, etc.) at both the project and the global level but I get that
error nevertheless;

2. I tried then using the instructions at 
<https://github.com/xamarin/XobotOS/tree/master/sharpen>   but when I've
added the repository I get a "There are no items available" when "Work with"
points to it. Do I need to build Sharpen beforehand and if so, why isn't it
reflected in the instructions?

Does anyone have a suggestion?

View this message in context: http://mono.1490590.n4.nabble.com/Sharpen-errors-tp4662850.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list