[Mono-list] Coding advice before I raise a bug

David Burnett vargol at ntlworld.com
Fri Jun 13 17:32:08 UTC 2014

On 13/06/2014 12:22, Edward Ned Harvey (mono) wrote:
>> From: mono-list-bounces at lists.ximian.com [mailto:mono-list-
>> bounces at lists.ximian.com] On Behalf Of David Burnett
>> Macintosh:Release vargol$ mono --version
>> Mono JIT compiler version 3.2.7 ((no/40f92d5 Thu Feb  6 18:29:16 EST 2014)
> A little bit outdated, but not too bad.

Yep, I've updated to 3.4.0 in the mean time, didn't realise I'd got out of date.

>> running on OSX 10.6.8, 32 bit edition.
> Eek.  You should probably show more concern about security updates...  But to each his own...

I'd love to be up to date but I'm one of the suckers that brought a 32bit Intel iMac.
We do still get the odd security update though, just no OS updates. At least we
still get Firefox and Chrome updates.

>> I've tried running the bad version using --llvm and it seems to work correctly.
>> A fresh compile against .net also works correctly.
> That is telling.

Yes it is, as soon as it was obvious that its wasn't an issue with code generation, I thought
trying it with llvm code generation might yield different results.

> Actually, I observe, that as long as the debugger is attached, the program runs without any problem.  As long as there's no debugger, then it crashes.  So I agree that sounds like a bug.  I'm not just talking about running the project in Debug vs Release mode...  I mean...

I've raised a bug on bugzilla, 20562

> In Release build, launch with debugging.  It runs to completion, and I get this command line:
> "/Library/Frameworks/Mono.framework/Versions/3.4.0/bin/mono"  --debug --debugger-agent=transport=dt_socket,address= "/Users/eharvey/Projects/PhotonPump/SunflowSharp.Test/bin/Release/SunflowSharp.Test.exe" /Users/eharvey/Projects/PhotonPump/examples/particle_chau.sc

I've never managed to get the debugger to work to be honest. I usually do some sneaky debugging on the Win 7 work laptop
when debug prints don't do the trick. Of course I'm also stuck with Monodevelop 4 on the creaky old iMac :-)


More information about the Mono-list mailing list