[Mono-list] Using mod-mono from source

Andy York andy at brdstudio.net
Fri Jul 12 23:55:34 UTC 2013

My money is on Ubuntu being the issue, it seems like Ubuntu users have more than than the average amount of issues. Not because it's a bad distro but because it doesn't seem to use the standard Linux setup, for example they seem to use different ports for web servers.

This is an uneducated guess, I don't have documentation to back me up.
Sent from my Nexus 7, typing with my thumbs makes it easy to make errors & is painfully slow, please excuse my brevity.

Martin Thwaites <monoforum at my2cents.co.uk> wrote:
>Thanks Daniel,
>I've tried that now, and it seems that there might be a more underlying
>problem as I'm getting a similar error as the mod-mono-server, in that
>appears to be passing the parameter name into the parameter value. So I
>think there is a problem with either:
> - My installation (not sure how as it's a basic ubuntu 13.04, and I've
>   reinstalled a few times)
>   - The mono code base
>   - The mono options class (not sure if that's part the main mono code
>   base?)
>   - The xsp code base.
>My money is on either a problem with compiling the mono code base, or
>problems with changes in the xsp code base.  Looking at the recent
>on XSP, there was a change to use the ConfigurationManager class very
>Do you use Ubuntu/debian? and do you have the facility to test the
>commits of mono/xsp?  or anyone else for that matter?
>On Fri, Jul 12, 2013 at 11:46 AM, Daniel Lo Nigro <lists at dan.cx> wrote:
>> You could also try using FastCGI instead (although that would involve
>> changing your config a bit)
>> On Fri, Jul 12, 2013 at 8:42 PM, Martin Thwaites
><monoforum at my2cents.co.uk
>> > wrote:
>>> I've now tried with/without the "=" using the mod-mono-server4.exe
>>> directly, and no joy.
>>> Did you run your source directly from Git with all the latest
>>> and if so, what date did you do it?
>>> Thanks
>>> On Fri, Jul 12, 2013 at 10:06 AM, Martin Thwaites <
>>>> monoforum at my2cents.co.uk> wrote:
>>>>> Hi Mike,
>>>>> I've tried every combination of parameters I can think of,
>>>>> adding/removing the "=", as well as reordering (not that it should
>have an
>>>>> effect, but who knows what bugs might be lurking).
>>>>> I'll try the nonstop and root, and I'll also try running it
>>>>> from the exe instead of the bash script (thinking about it, that
>is one of
>>>>> the big differences and I'm actually optimistic about that being
>the issue
>>>>> as looking at the code, applications is a recently added option).
>>>>> I'll let you know how I get on, I've sent a mail to the devel list
>>>>> Thanks,
>>>>> Martin
>>>>> On Fri, Jul 12, 2013 at 4:11 AM, Mike Morano
><mmorano at mikeandwan.us>wrote:
>>>>>> Hi Martin,
>>>>>> Sorry, you are still running into problems.  You are right, if
>you are
>>>>>> using /usr as your prefix, you shouldn't need to worry about the
>>>>>> ld.conf.so.d entry.
>>>>>> When I look at the command on my running webserver, I see the
>>>>>> following:
>>>>>> /opt/mono-3.0/bin/mono
>>>>>> --filename /tmp/mod_mono_server_site --applications
>>>>>> --nonstop --root /srv/www/site
>>>>>> Seeing you are using the default prefix, you should be fine with
>>>>>> /usr/bin/mod-mono-server4 as you have it.  However, perhaps it
>doesn't like
>>>>>> the format you are specifying the arguments (try dropping the
>'='), or
>>>>>> perhaps try adding the nonstop and root arguments.
>>>>>> Does that get you any further?
>>>>>> -m
>>> _______________________________________________
>>> Mono-list maillist  -  Mono-list at lists.ximian.com
>>> http://lists.ximian.com/mailman/listinfo/mono-list
>Mono-list maillist  -  Mono-list at lists.ximian.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-list/attachments/20130712/8d52c9c0/attachment.html>

More information about the Mono-list mailing list