[Mono-list] Installing mono for Linux

vinny77 vcharles at free.fr
Sat Feb 16 07:47:23 UTC 2013

Hello, I have tried to add this when running the sh file : --prefix=/usr/lib/
(I have double checked and mono is installed in this folder /usr/lib/mono).

The installation could not worked, but now I got this error message :

16/02/2013 08:42:55	Error	An uncaught thread exception was detected	
skipping	An exception was thrown by the type initializer for
System.Windows.Forms.XplatUI	  at
System.Windows.Forms.Application.EnableVisualStyles () [0x00000] in
<filename unknown>:0  -   at TransmissionApplicationUploader.Program.Main ()
[0x00000] in <filename unknown>:0 	An exception was thrown by the type
initializer for System.Windows.Automation.Provider.AutomationInteropProvider	 
at Mono.UIAutomation.Winforms.FormListener.Initialize () [0x00000] in
<filename unknown>:0  -   at Mono.UIAutomation.Winforms.Global.Initialize ()
[0x00000] in <filename unknown>:0  -   at (wrapper managed-to-native)
System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod
object	object[]	System.Exception&) -   at
System.Reflection.MonoMethod.Invoke (System.Object obj	 BindingFlags
invokeAttr	 System.Reflection.Binder binder	 System.Object[] parameters	
System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0 
Method not found: 'System.Type.op_Equality'.	  at
System.Windows.Automation.Provider.BridgeManager.GetAutomationBridges ()
[0x00000] in <filename unknown>:0  -   at
System.Windows.Automation.Provider.AutomationInteropProvider..cctor ()
[0x00000] in <filename unknown>:0 

Maybe this could help to find why it is not working ?

Thanks for any advice

PS : mono version is 2.10

View this message in context: http://mono.1490590.n4.nabble.com/Installing-mono-for-Linux-tp4658570p4658605.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list