[Mono-list] Latest Mono and MonoDevelop packages for CentOS, Fedora, Debian and Ubuntu on OBS

Timotheus Pokorra timotheus.pokorra at solidcharity.com
Fri Aug 2 07:12:17 UTC 2013

Hello Mark,

thanks for contacting me on this.
It was my mistake: I did reorganize the packages yesterday, and forgot
to add the dependancy for mono-opt-devel to the monodevelop-opt
I have fixed it on OBS, it will be part of the next release.

I saw the same problems you had, but this line fixed it:
yum install mono-opt-devel

Then MonoDevelop starts fine from the application menu, which is
referencing the script /usr/bin/monodevelop-opt:
export PATH=/opt/mono/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin;export
LD_LIBRARY_PATH=/opt/mono/lib:; /opt/monodevelop/bin/monodevelop

I have recently included a script /opt/mono/env.sh which sets the
paths as well, for using mono in general.

Here the versions that I have used for CentOS, and it works for me:
[root at j56980 ~]# cat /etc/redhat-release
CentOS release 6.4 (Final)
[root at j56980 ~]# rpm -qa  | grep mono

Please let me know if that works, or if you still get errors.

Thank you for letting me know!

All the best,

On 2 August 2013 04:47,  <mlintner at flash.net> wrote:
> Hi,
> I have Centos 6.4 and have been trying to build the latest monodevelop from git. Its tough and I decided to forget it and use your packages. I'm sending a friendly email letting you know neither mono or monodevelop work. Mono can be fixed by putting it in the path. Monodevelop blows up because of the shell script. The case for the executable is wrong and there are other issues. Finally when I bore down to the executable and run it I get this output
> [root at mlintner-centos bin]# mono ./monodevelop.exe
> Cannot open assembly './monodevelop.exe': No such file or directory.
> [root at mlintner-centos bin]# mono ./MonoDevelop.exe
> System.TypeInitializationException: An exception was thrown by the type initializer for Mono.Unix.Native.Syscall ---> System.DllNotFoundException: libMonoPosixHelper.so
>   at (wrapper managed-to-native) Mono.Unix.Native.Syscall:get_at_fdcwd ()
>   at Mono.Unix.Native.Syscall..cctor () [0x00000] in <filename unknown>:0
>   --- End of inner exception stack trace ---
>   at MonoDevelop.Core.LoggingService.RedirectOutputToFileUnix (FilePath logDirectory, System.String logName) [0x00000] in <filename unknown>:0
>   at MonoDevelop.Core.LoggingService.RedirectOutputToLogFile () [0x00000] in <filename unknown>:0
> FATAL ERROR [2013-08-01 22:31:47Z]: MonoDevelop failed to start. Some of the assemblies required to run MonoDevelop (for example gtk-sharp)may not be properly installed in the GAC.
> System.DllNotFoundException: glibsharpglue-2
>   at (wrapper managed-to-native) GLib.Marshaller:glibsharp_strlen (intptr)
>   at GLib.Marshaller.Utf8PtrToString (IntPtr ptr) [0x00000] in <filename unknown>:0
>   at GLib.Marshaller.PtrToStringGFree (IntPtr ptr) [0x00000] in <filename unknown>:0
>   at Gtk.Rc.get_ModuleDir () [0x00000] in <filename unknown>:0
>   at MonoDevelop.Ide.IdeStartup.SetupTheme () [0x00000] in <filename unknown>:0
>   at MonoDevelop.Ide.IdeStartup.Run (MonoDevelop.Ide.MonoDevelopOptions options) [0x00000] in <filename unknown>:0
>   at MonoDevelop.Ide.IdeStartup.Main (System.String[] args) [0x00000] in <filename unknown>:0
> I used the button off of Centos on your install page.
> Then used the procedure that sets up the repository and then yum installs it
> If you would fix it before tomorrow it would be wonderful but I guess I have to go back and figure out why mine is not building. I was very close but the procedure takes a couple of tedious hours as far as I got. Actually I built it and it runs but I had to change some csharp code to do it. I turned it in as a bug but since you were building it I decided the bug couldn't be right. So Im looking at the version of gtk Im building. With a higher version the code bug is still there so I don't know.
> Thanks
> Let me know what you think.
> Mark
> <quote author='Timotheus Pokorra'>
> Hello,
> I have now built rpm and deb packages of the latest Mono (3.2) and
> MonoDevelop (4.0.10) on Open Build Service:
> https://build.opensuse.org/project/show/home:tpokorra:mono
> You can install it on Debian 6 and 7, Ubuntu 12.04 and 13.04, CentOS
> 6, Fedora 17 and 18.
> If there is interest for a SUSE rpm, I could work on that as well.
> The installation for MonoDevelop is documented here:
> http://software.opensuse.org/download/package?project=home:tpokorra:mono&package=monodevelop-opt
> This will install Mono as well.
> if you only want to install Mono, see here:
> http://software.opensuse.org/download/package?project=home:tpokorra:mono&package=mono-opt
> Please let me know if you find any problems with those.
> All the best,
>   Timotheus
> _______________________________________________
> Mono-list maillist  -  Mono-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-list
> </quote>
> Quoted from:
> http://mono.1490590.n4.nabble.com/Latest-Mono-and-MonoDevelop-packages-for-CentOS-Fedora-Debian-and-Ubuntu-on-OBS-tp4660330.html
> _____________________________________
> Sent from http://mono.1490590.n4.nabble.com

More information about the Mono-list mailing list