[Mono-list] Getting "System.MissingMethodException: Method not found: 'OfficeDrop.Sync.Application.ReplicaTest.DoWithPaths'" when running test from nunit-console

Rodrigo Kumpera kumpera at gmail.com
Fri Jul 20 18:12:55 UTC 2012

You probably have a state reference of that assembly laying around and mono
is picking it up instead of the one you
meant it to. do a "grep -rl ReplicaTest" on your project root and try to
remove duplicate stale assemblies."

On Fri, Jul 20, 2012 at 12:21 PM, Maurício Linhares <
mauricio.linhares at gmail.com> wrote:

> I'm trying to run some tests from the command line and I'm getting this
> error:
> System.MissingMethodException: Method not found:
> 'OfficeDrop.Sync.Application.ReplicaTest.DoWithPaths'.
> I do know this method is in there because it is part of my class, so it
> doesn't really make sense that is isn't in there, here's the full stack
> trace:
> https://gist.github.com/41a164e5332bef415847
> When I run this inside of MonoDevelop it works, it only fails when I run
> it from the command line.
> -
> Maurício Linhares
> http://techbot.me/ - http://twitter.com/#!/mauriciojr
> _______________________________________________
> Mono-list maillist  -  Mono-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-list
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-list/attachments/20120720/dbaecd63/attachment.html>

More information about the Mono-list mailing list