[Mono-list] can't build master branch: missing mdoc.exe

Louis Salin louis.phil at gmail.com
Sun Jan 8 15:16:18 EST 2012


I cloned the git repo (master branch) and did the following:


which got the following error:

make[6]: Entering directory
make all-local
make[7]: Entering directory
MDOC    [net_4_5] cs-errors.tree
Cannot open assembly './../tools/mdoc/mdoc.exe': No such file or directory.
make[7]: *** [cs-errors.tree] Error 2
make[7]: Leaving directory
make[6]: *** [do-all] Error 2
make[6]: Leaving directory
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/louis/.mopem/sources/2.10-HEAD/mono/mcs'
make[4]: *** [profile-do--net_4_5--all] Error 2
make[4]: Leaving directory `/home/louis/.mopem/sources/2.10-HEAD/mono/mcs'
make[3]: *** [profiles-do--all] Error 2
make[3]: Leaving directory `/home/louis/.mopem/sources/2.10-HEAD/mono/mcs'
make[2]: *** [all-local] Error 2
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/louis/.mopem/sources/2.10-HEAD/mono'
make: *** [all] Error 2

I took a look at the build output and it seems that the mdoc tool isn't
being built. I saw a "nothing to do" in there. If anyone needs it, I can
generate a log that demonstrates this.

After a bit of googling, I tried skipping the doc building process with:


and that worked.
However, I don't remember having any issues building the master or 2.10
branch for the git repo in the past.
I can't tell if I changed something on my system or if the build process

Ideally, I'd like to just type "make" and build mono, including the docs.
If anyone knows what my issue might be, I'd really appreciate it.


Louis Salin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-list/attachments/20120108/522f099a/attachment.html 

More information about the Mono-list mailing list