[Mono-list] Just can't get MVC 3 w/ Razor to work on Mono 2.11 & Ubuntu 12.4

Monkeyface msgbox450 at gmail.com
Wed Aug 1 09:34:42 UTC 2012

I have also been trying to get MVC3 things working on Mono for several months
and it's been driving me crazy. 

If you run a version of mono 2.10 and copy all the MVC3 libraries locally to
the bin folder, it can run the application but I haven't been able to get
anything I can work with and test easily in Monodevelop and other
shortcomings of mono 2.10 mean it can't run any more complex web
applications like Orchard (which I am trying to use). It does run an old
version of Orchard with lots of tweaking and patching but even then it will
only load a few pages before going wrong.

With the very latest Mono 2.11.2 build for Windows and the latest
Monodevelop alpha the change logs suggest MVC3 should work, and there's an
MVC3 template there in Monodevelop, but sadly it still doesn't work out of
the box on the mono runtime and has missing libraries.
Change the runtime to target 4.5 and the MVC3 libraries are available,
except for System.Web.Helpers. Remove that and I can get it to build, but
the debugger still doesn't like it and gives me
"System.NotSupportedException: Stream does not support reading"

I tried going the old-school route of targetting .NET 4 and copying all the
libraries for Orchard to the bin folder. It then complained of missing
references which VS didn't... I had to add System.Data to every single
plugin project to get them to build because it didn't resolve automatically.
With some tweaking I then got orchard to build... but alas it still won't
run because XSP itself just crashes out completely.


It's sad because it seems we're really close to being able to run Orchard
and other big .NET MVC3 apps on Mono but we're not quite there yet and I
perceive that development effort is mainly on the mobile stuff and unity
support because that's where the $$$ comes from for Xamarin (which is fair
enough I guess, but frustrating for web folks).

View this message in context: http://mono.1490590.n4.nabble.com/Just-can-t-get-MVC-3-w-Razor-to-work-on-Mono-2-11-Ubuntu-12-4-tp4650644p4650675.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list