[Mono-list] SqlBulkCopy Error: Incorrect syntax near ','

dconroy dsconroy at gmail.com
Sun Oct 9 15:29:53 EDT 2011

Hi - 

I am getting exactly the same error as described here. I am using mono 2.10
on Ubuntu 11.04.

I'm a bit of a newbie here - so go easy. As per the OP I'm trying to port
some code that works perfectly under windows onto mono running on Ubuntu and
I get the exact same error message.

I can connect from mono to SQLServer just fine and get SQLDataReaders back
no prob - but i'd like to bulkcopy some data in . . The full error msg is

Many thanks!

ystem.Data.SqlClient.SqlException: Incorrect syntax near ','.
  at System.Data.SqlClient.SqlConnection.ErrorHandler (System.Object sender,
Mono.Data.Tds.Protocol.TdsInternalErrorMessageEventArgs e) [0x00000] in
<filename unknown>:0 
  at Mono.Data.Tds.Protocol.Tds.OnTdsErrorMessage
(Mono.Data.Tds.Protocol.TdsInternalErrorMessageEventArgs e) [0x00000] in
<filename unknown>:0 
  at Mono.Data.Tds.Protocol.Tds.ProcessMessage (TdsPacketSubType subType)
[0x00000] in <filename unknown>:0 
  at Mono.Data.Tds.Protocol.Tds.ProcessSubPacket () [0x00000] in <filename
  at Mono.Data.Tds.Protocol.Tds.NextResult () [0x00000] in <filename
  at Mono.Data.Tds.Protocol.Tds.SkipToEnd () [0x00000] in <filename
  at Mono.Data.Tds.Protocol.Tds.ExecBulkCopyMetaData (Int32 timeout, Boolean
wantResults) [0x00000] in <filename unknown>:0 
  at Mono.Data.Tds.Protocol.TdsBulkCopy.SendColumnMetaData (System.String
colMetaData) [0x00000] in <filename unknown>:0 
  at System.Data.SqlClient.SqlBulkCopy.BulkCopyToServer
(System.Data.DataTable table, DataRowState state) [0x00000] in <filename
  at System.Data.SqlClient.SqlBulkCopy.WriteToServer (System.Data.DataTable
table) [0x00000] in <filename unknown>:0

View this message in context: http://mono.1490590.n4.nabble.com/SqlBulkCopy-Error-Incorrect-syntax-near-tp1507008p3888224.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list