[Mono-list] Using mono aot / aot-full compilation: nothing appears to happen?

applepi chrisddail at gmail.com
Mon Nov 7 13:15:01 EST 2011

I've got a C# project that I need compiled to a native binary. I've read here
on the AOT page that Mono can precompile an assembly to one of two options:

--aot : A precompiled image (essentially the same as Ngen as it looks to me)
--aot=full: A fully compiled to native binary instance of the original .exe

I am fairly sure I'm understanding those right, but could be wrong about the
--aot=full option.

However, when I run:

 mono.exe --aot=full --verbose program.exe  

I get no output, the last modified date on the executable remains the same,
and no files are generated. I've also tried just as a test:

 mono.exe --aot --verbose program.exe 

I get the same result; no output, no image file or files in general,

Am I missing something here?

View this message in context: http://mono.1490590.n4.nabble.com/Using-mono-aot-aot-full-compilation-nothing-appears-to-happen-tp4010058p4010058.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list