[Mono-list] mod-mono apache asp.net request cancelled by other request

Peter Hagen peter at wingsofdeath.net
Thu Jun 9 15:02:42 EDT 2011


today I found an issue with my mono 2.10.2 + apache setup, which I cant
figure out what is wrong with it. Hopefully someone has some similar
experience. I run a site, which has a aspx page, but also uses
iHttpHandler's. There is a handler that queries the database and with
small buffers sends it to the client. For this the Response.BufferOutput
is set to false, and that works perfectly. It starts downloading
directly. Today I was testing a big fill on our development site, which
runs on the same machine as the live site, and suddenly noticed, on the
apache server, that while during the download, and I called another
request, even from another host, my download is cancelled. I tested it
after that with XSP on the same machine (and later on another server)
and there it works without a problem. So it seems to be a combination
with mod-mono or apache maybe. In all cases, I see first a message like
this in the error.log (the number changes):

[Thu Jun 09 20:44:48 2011] [error] Unknown command: 2004184946

And after that the exception is posted to the error log:

[vspdev|09-06-2011 20:45:18|11] Exception in
[vspdev|09-06-2011 20:45:18|11] System.Net.Sockets.SocketException
[vspdev|09-06-2011 20:45:18|11] The socket has been shut down
[vspdev|09-06-2011 20:45:18|11]   at System.Net.Sockets.Socket.Send
(System.Byte[] buf, Int32 size, SocketFlags flags) [0x00000] in
<filename unknown>:0 
  at Mono.WebServer.ModMonoRequest.Send () [0x00000] in <filename
  at Mono.WebServer.ModMonoRequest.SendResponseFromMemory (System.Byte[]
data, Int32 position, Int32 length) [0x00000] in <filename unknown>:0 
  at Mono.WebServer.ModMonoWorker.Write (System.Byte[] buffer, Int32
position, Int32 size) [0x00000] in <filename unknown>:0 
  at Mono.WebServer.ModMonoWorkerRequest.SendResponseFromMemory
(System.Byte[] data, Int32 length) [0x00000] in <filename unknown>:0 
  at System.Web.HttpResponseStream.Write (System.Byte[] buffer, Int32
offset, Int32 count) [0x00000] in <filename unknown>:0 
  at System.Web.HttpWriter.WriteString (System.String s, Int32 index,
Int32 count) [0x00000] in <filename unknown>:0 
  at System.Web.HttpWriter.Write (System.String s) [0x00000] in
<filename unknown>:0 
  at Willow.Data.Converter.CsvStorage.Save () [0x00000] in <filename
  at Willow.Data.Converter.CsvStorage.Dispose () [0x00000] in <filename
  at Willow.Cms.Common.CollectionPlugin.CollectionToFile
(System.Web.HttpResponse response, iCmsFormControlValues values,
Willow.Cms.Common.ActionResult result, iWillowDataCollection collection,
System.String TempFile, System.String OutputFilename, System.String
Filetype, Willow.Common.WillowXmlElement FileSettingsXml) [0x00000] in
<filename unknown>:0 
  at Willow.Cms.Common.WillowFormControl.DownloadCollection
(Willow.Cms.Common.ActionResult result, System.String Filename,
System.String Filetype, iWillowDataCollection collection,
Willow.Common.WillowXmlElement FileSettingsXml) [0x00000] in <filename
  at Willow.Cms.Common.WillowFormControl.DownloadFile
(Willow.Cms.Common.ActionResult result, Willow.Common.WillowXmlElement
xml) [0x00000] in <filename unknown>:0 

Somehow, the socket is just being closed. As far as I know, this is
happening since today, but I also tried older revisions of the code, and
they have the same effect. While searching for an answer, I also
restarted the server and after that the live site does the same thing. i
cant be 100% sure that the live site (with a bit older code) was working
100% ok before. So, anyone any idea? Been searching, testing and trying
all day, and have no clue were to look for this. 



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-list/attachments/20110609/225f096d/attachment-0001.html 

More information about the Mono-list mailing list