[Mono-list] [Solved] I can't debug any openTK app

Daniel Soto daniel.soto2k at gmail.com
Mon May 3 01:55:57 EDT 2010


I only want to notice to the list, that finally I solved this problem,
when debugging an openGl/openTK application.

I believe that forgot to mention that I use Ubuntu, so, I use Mono
compiling it from tarball and not use Mono installation from
repositories, because they are very outdated in Ubuntu.

The reason was that, in this days, a new version of Ubuntu was released
(10.04 Lucid Lynx), and was strange, in my system I not have ANY package
of Mono installed from repositories, however, after upgrade, appears
some packages libmono-runtime, libmono-corlib and others installed (i'm
not sure if some dependencies are missing). So, they caused some
conflicts with my custom installation of mono from tarball, causing mono
debugger to crash.

So, I proceeded to uninstall these packages, run apt-get autoremove, and
clear missing dependencies with apt-get autoclean. Then, I reinstalled
mono-debugger, monodevelop-debugger addin, and monodevelop IDE, all
compiling again from tarball, and then all back to work. Now, the
debugger and IDE works fine, and the error that I described, dissapears.

So, if someone have this problem, take care of mono automatic
installation if upgrade to Lucid Lynx, it can cause problems.

Thanks for your time and patience.

Kind regards.


More information about the Mono-list mailing list