[Mono-list] DllNotFound - but the dll is there...

Ocirne94 ocirne94 at gmail.com
Fri Jun 11 06:32:23 EDT 2010

Hello everybody,
I have Ubuntu 10.04 64-bit, and I have been trying to run RouteViewer
program (http://openbve.trainsimcentral.co.uk/common/tool_routeviewer.zip)
under Mono for some time; I have copied Tao.OpenGl.dll, Tao.OpenAl.dll and
Tao.Sdl.dll with their config files from Mono folder to program's folder, in
order to get it to work; the program started, but trying to load any file
from it caused a Segmentation fault. I imagined that it could be because of
the fact that RouteViewer needed 32-bit libraries, while dll config files
pointed to 64-bit ones: in Tao.OpenAl.dll.config, for example, I had

<dllmap dll="OpenAL32.dll" os="!windows,osx" target="libopenal.so.1.4.272"

But changing the library to 32-bit version raised the following error:

Unhandled Exception: System.DllNotFoundException: libopenal.so.1.4.272
  at (wrapper managed-to-native) Tao.OpenAl.Alc:alcOpenDevice (string)
  at OpenBve.SoundManager.Initialize () [0x00000] in <filename unknown>:0 
  at OpenBve.Program.Main (System.String[] Args) [0x00000] in <filename

I thought that it was because a 64-bit Mono needed 64-bit libraries, so I
tried to compile a 32-bit version into /usr/local, instead of /usr (where I
have the 64-bit one), but I wasn't able to: what I did was changing Makefile

arch_target = amd64


arch_target = i386,

but I still get the DllNotFound error.
The Mono version I tried to compile was


Any tips?
Thanks in advancem
View this message in context: http://mono.1490590.n4.nabble.com/DllNotFound-but-the-dll-is-there-tp2251585p2251585.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list