[Mono-list] mod_mono - Symbol not found _strndup/n

jcargilo jcargilo at gmail.com
Fri Feb 12 21:34:03 EST 2010

Let me start of by saying thank you to all those that respond and have
responded elsewhere as I've spent around 10 hours now trying to get this
solution up and running and have found help in various posts.  My situation
is that I'm trying to setup Mono and the associated mod_mono module for
apache2 on a mac mini server running Snow Leopard.  Coming from a pure
Microsoft .NET environment, I've learned a bit quickly over the last couple
days.  I managed to get mono and xsp installed, worked around the slew of
pkg-config is not installed error messages, and tested mono and mono develop
on xsp's test server port 8080 and to that point I've had some success.

I managed to get mod_mono to compile using the following basic commands:

./configure CFLAGS="-64m" --prefix=/usr
sudo make install

and the module was installed in the proper directory (although the
httpd.conf was NOT updated automatically as the instructions said it would
be).  I tried the Auto method including the mod_mono.conf file as well as
simply loading the module and both return an error message indicating:
Symbol not found _strndup/n.  The exact error message is unavailable to me
as my access to the mac mini server is through VNC on my PC, and I'm
temporarily unable to log back in.  The apache error message indicated that
it was originating from the mod_mono.so file, and I've seen mention of this
issue in previous builds of the mod_mono module on the web with something
having to do with strndup not being available on OSX.

At any rate, I'm at my wits end and I really want to get this solution
working and start using Mono on Snow Leopard.  

Any suggestions?
View this message in context: http://n4.nabble.com/mod-mono-Symbol-not-found-strndup-n-tp1502025p1502025.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list