[Mono-list] Web.config path access to directory

Abe Gillespie abe.gillespie at gmail.com
Mon Dec 6 11:35:27 EST 2010

Hmm ... would you mind helping me apply this patch?  These are the
steps I've tried:

1.  Copied from "diff --git" to "}" and placed this into "patch.diff"
in my root mono-2.8.1 source.
2.  from mono-2.8.1 executed "patch -p0 < patch.diff"

I get:
can't find file to patch at input line 7
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
|diff --git
|index b8a3df7..6f80617 100644
|--- a/mcs/class/System.Configuration/System.Configuration/Configuration.cs
|+++ b/mcs/class/System.Configuration/System.Configuration/Configuration.cs
File to patch:


On Mon, Dec 6, 2010 at 7:22 AM, Mike Morano <mmorano at mikeandwan.us> wrote:
> I've run into something similar, perhaps the patch that worked for me
> could also work for you:
> https://bugzilla.novell.com/show_bug.cgi?id=467221
> On Sun, Dec 5, 2010 at 14:49, Abe Gillespie <abe.gillespie at gmail.com> wrote:
>> This use to work:
>>  <location path="common">
>>    <system.web>
>>      <authorization>
>>        <allow users="*"/>
>>      </authorization>
>>    </system.web>
>>  </location>
>> Where "common" is a directory and I want to grant access to everything
>> under it like images, css, and scripts before logging in.  I believe
>> this is a regression and saw this same bug surface and get fixed a few
>> years back.
>> I don't mind filing a bug but would someone point me to where in the
>> source I can quickly patch this to get running again?
>> Thanks.
>> -Abe
>> _______________________________________________
>> Mono-list maillist  -  Mono-list at lists.ximian.com
>> http://lists.ximian.com/mailman/listinfo/mono-list

More information about the Mono-list mailing list