[Mono-list] mono-service2 debugging issues

David Jagoe davidjagoe at gmail.com
Mon Dec 6 00:27:13 EST 2010


On Monday, 6 December 2010, Abe Gillespie <abe.gillespie at gmail.com> wrote:
> Hello,
> I'm trying to run my service as a daemon.  It doesn't run and the only
> thing I get in the system log is:
> Dec  6 05:04:22 machine mono: Service.exe: A type load exception has occurred.
> I've tried a number of things to coerce more info out of mono but I
> can't seem to.  Is there any way to get the full exception message /
> stack trace?  Also, the service runs fine if I run it directly instead
> of through mono-service.

I've battled with this a few weeks ago. In answer to your first
question, try running mono-service2 with the --debug option. That
should print stack traces.

Hopefully once you see stack trace you'll be able to figure out why
there is a difference when running as a service. In my case the
problem appeared to be importing code from a different filesystem.


> Thanks.
> -Abe
> _______________________________________________
> Mono-list maillist  -  Mono-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-list

More information about the Mono-list mailing list