[Mono-list] issues mono 2.8(.1)

Peter Hagen peter at wingsofdeath.nu
Wed Dec 1 07:46:49 EST 2010

Hi again,

I think I solved this issue with the 2.8+ Mono and the sometimes
stalling pages. With the fix that was mentioned earlier in the mailing
list, I updated the  
mcs/class/System.Web/System.Web.Configuration_2.0/MachineKeyRegistryStorage.cs. And now at some random times i get the exception that is instead of been thrown, being printed to console:

(info) Auto generated encryption keys not saved:
System.Security.SecurityException: No access to the given key
  at Microsoft.Win32.KeyHandler..ctor (Microsoft.Win32.RegistryKey rkey,
System.String basedir, Boolean is_volatile) [0x00000] in <filename
  at Microsoft.Win32.KeyHandler..ctor (Microsoft.Win32.RegistryKey rkey,
System.String basedir) [0x00000] in <filename unknown>:0 
  at Microsoft.Win32.KeyHandler.Lookup (Microsoft.Win32.RegistryKey
rkey, Boolean createNonExisting) [0x00000] in <filename unknown>:0 
  at Microsoft.Win32.UnixRegistryApi.OpenSubKey
(Microsoft.Win32.RegistryKey rkey, System.String keyname, Boolean
writable) [0x00000] in <filename unknown>:0 
  at Microsoft.Win32.RegistryKey.OpenSubKey (System.String name, Boolean
writable) [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check)
Microsoft.Win32.RegistryKey:OpenSubKey (string,bool)
  at System.Web.Configuration.MachineKeyRegistryStorage.OpenRegistryKey
(System.String path, Boolean write) [0x00000] in <filename unknown>:0 
  at System.Web.Configuration.MachineKeyRegistryStorage.Store
(System.Byte[] buf, KeyType kt) [0x00000] in <filename unknown>:0 

This is after somewhere after the unload of the page, and the reason why
the client browser never gets the entire page loaded. So, resolved!



On Tue, 2010-11-30 at 12:17 +0100, Peter Hagen wrote:

> Hi
> I have been testing out the 2.8+ release for my Asp.net application,
> running with mod-mono. At first the site looked faster then before, but
> some times I notice that (at random) a page stops loading, and after a
> while (10+ seconds some times) it goes on. Mostly on giving a refresh it
> loads again. Could this have anything to do with the stop_world() and
> restart_world() principle of the new Garbage Collection?
> Yesterday I tried the site with SGEN by modifying
> the /usr/bin/mod-mono-server2 like this:
> exec /usr/bin/mono --gc=sgen $MONO_OPTIONS
> "/usr/lib/mono/2.0/mod-mono-server2.exe" "$@"
> and the result was eventually, that my entire memory was been eaten by
> the mono process. Is this a known issue? Maybe it was just an issue
> because of not completely restarting apache or something. I didnt dare
> to try it again, cause its a live site. 
> In several different situations (with different sites on different
> machines) I noticed the stuttering of the website. This is all with
> 2.8.1 (2.8.0 also did it) and one machine is a Debian 4 version while
> the other is a Ubuntu 10.4 running in VirtualBox. It happens with and
> without SGEN enabled. Any ideas about this?
> Cheers
> Peter
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-list/attachments/20101201/d4d65922/attachment-0001.html 

More information about the Mono-list mailing list