[Mono-list] Error Loading UIA Bridge After Upgrade to 2.6.4

Sandy Armstrong sanfordarmstrong at gmail.com
Tue Apr 27 11:31:05 EDT 2010

On Tue, Apr 27, 2010 at 8:29 AM, Sandy Armstrong
<sanfordarmstrong at gmail.com> wrote:
> On Tue, Apr 27, 2010 at 8:09 AM, Brian Kesecker
> <bkesecker at augustasystems.com> wrote:
>> I am getting the following exception after upgrading from repo mono-stable to
>> 2.6.4 (previously 2.6.3).  Fortunately, this does not crash my application.
>> I tried downgrading to what I had previously, but the same error persisted.
>> Rebooted, still the same.  This occurs on two of the machines I'm working
>> with, both's OSs were installed with the Mono 2.6.1 iso.  On another, that I
>> access via UltraVNC, I get "Cannot set X locale modifiers" instead.
>> Any thoughts what I messed up?
>> [0xb74f86f0:] EXCEPTION handling: FileNotFoundException
>> Error loading UIA bridge (UiaDbusBridge, Version=, Culture=neutral,
> This error is just to let you know that you are missing that UIA
> bridge, which enhances usage of the UIA Client API for Winforms
> applications.
> You can make the error go away by installing UiaDbusBridge.

By the way, to be clear...the package you upgraded that made this
start happening is undoubtedly mono-uia.


More information about the Mono-list mailing list