[Mono-list] Error Loading UIA Bridge After Upgrade to 2.6.4

Brian Kesecker bkesecker at augustasystems.com
Tue Apr 27 11:09:55 EDT 2010

I am getting the following exception after upgrading from repo mono-stable to
2.6.4 (previously 2.6.3).  Fortunately, this does not crash my application. 
I tried downgrading to what I had previously, but the same error persisted. 
Rebooted, still the same.  This occurs on two of the machines I'm working
with, both's OSs were installed with the Mono 2.6.1 iso.  On another, that I
access via UltraVNC, I get "Cannot set X locale modifiers" instead.

Any thoughts what I messed up?

[0xb74f86f0:] EXCEPTION handling: FileNotFoundException
Error loading UIA bridge (UiaDbusBridge, Version=, Culture=neutral,
PublicKeyToken=f4ceacb585d99812): System.IO.FileNotFoundException: Could not
load file or assembly 'UiaDbusBridge, Version=, Culture=neutral,
PublicKeyToken=f4ceacb585d99812' or one of its dependencies. The system
cannot find the file specified.
File name: 'UiaDbusBridge, Version=, Culture=neutral,
  at System.AppDomain.Load (System.String assemblyString,
System.Security.Policy.Evidence assemblySecurity, Boolean refonly) [0x00000]
in <filename unknown>:0 
  at System.AppDomain.Load (System.String assemblyString) [0x00000] in
<filename unknown>:0 
  at (wrapper remoting-invoke-with-check) System.AppDomain:Load (string)
  at System.Reflection.Assembly.Load (System.String assemblyString)
[0x00000] in <filename unknown>:0 
  at System.Windows.Automation.Provider.BridgeManager.GetAutomationBridge
(System.String bridgeAssemblyName) [0x00000] in <filename unknown>:0 

Brian Kesecker, Software Developer, Augusta Systems, Inc.
View this message in context: http://mono.1490590.n4.nabble.com/Error-Loading-UIA-Bridge-After-Upgrade-to-2-6-4-tp2067736p2067736.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list