[Mono-list] Web.Services.Description.ServiceDescription.Read Type Initializer Exception

Brian Kesecker bkesecker at augustasystems.com
Mon Apr 26 12:15:47 EDT 2010

The setup:

Non-VM openSuSE 11.2
Mono 2.6.3 with nearly all other supporting libraries up-to-date (the
exception is gtk-complete)
Visual Studio 2008 and MonoVS 1.0 running on Windows 7 remotely debugging to
the above machine

The problem:

throws a type initializer exception on every web service I've tried (where
MyWebResponseStream is a stream returned from a valid WebResponse object). 
All the web services I've tried work fine with the same code under Windows. 
There are differences in the debugging information returned by Mono vs.
Windows (attached/inserted as an image below).


Some thoughts:

Type initializer sounds to me like it couldn't find a definition for a type
that is in the returned XML/WSDL data.
Maybe I'm missing:
Something that should be called/added to
Something global that is specified differently in Mono vs. .NET?

The questions:

Has anyone else encountered this?
If so, were you able to work around it?
If not, any ideas/suggestions/recommendations?

Some publically accessible WSDLs I've accessed:


Brian Kesecker, Software Developer, Augusta Systems, Inc.
View this message in context: http://mono.1490590.n4.nabble.com/Web-Services-Description-ServiceDescription-Read-Type-Initializer-Exception-tp2065397p2065397.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list