[Mono-list] Could not find respack and Systems.Windows missing when build Moonlight app

Ekarin Supataratarn ekarin.sup at gmail.com
Wed Nov 18 23:14:42 EST 2009

Great! That really solves my problem! I'm now up and running with
working MonoDevelop 2.2b2 on Ubuntu Jaunty using for moonlight
application development! Your help is greatly appreciated.

On Thu, Nov 19, 2009 at 9:06 AM, Michael Hutchinson
<m.j.hutchinson at gmail.com> wrote:
> On Wed, Nov 18, 2009 at 2:07 PM, Ekarin Supataratarn
> <ekarin.sup at gmail.com> wrote:
>> Hello,
>> I'm not quite sure that this problem is specific to monodevelop but I
>> have feeling that this might be a problem of compiling mono stack
>> instead, so I decided to put my questions here.
>> I tried to build MonoDevelop 2.2b2 on Ubuntu, since there is no
>> packaged build, to write my first moonlight application. However this
>> means either I have to use directhex's PPA or I may have to set up
>> parallel mono environment. I choose the later since by that time I
>> didn't realized existence of such Mono 2.4 family packages. Now I can
>> finally build MonoDevelop and open it as an application. However when
>> I create a new moonlight solution then I check References folder and
>> see System.Windows and Systems.Windows.Browser gone red. When I tried
>> to run the solution, "Could not find respack" error is always raised.
>> I'm not sure that this two problems might related or not but I'm
>> willing to solve both of them.
> The Moonlight SDK assemblies and commandline tools are not yet
> packaged. Please follow the instructions here:
> http://mjhutchinson.com/journal/2009/05/08/moonlight_development_linux_monodevelop
> --
> Michael Hutchinson
> http://mjhutchinson.com

More information about the Mono-list mailing list