[Mono-list] Mono XSP compile error

David Wilkinson dwilko at btopenworld.com
Wed Jul 22 14:35:47 EDT 2009


try this, worked for me when I had XSP compile errors

./configure --prefix=/usr/lib/mono --with-runtime=/opt/mono/bin/mono

Change /opt/mono/bin/mono to where you have installed mono



  ----- Original Message ----- 
  From: Ben Di Maggio 
  To: mono-list at lists.ximian.com 
  Sent: Wednesday, July 22, 2009 7:04 PM
  Subject: [Mono-list] Mono XSP compile error

  Hi all -- 
  I've been trying for a few hours now to get XSP running on my Red Hat EL4 box, to no avail. I'm able to configure it fine, but make produces this:

  Making all in man
  make[1]: Entering directory `/root/src/xsp-2.4.2/man'
  cp xsp.1 mod-mono-server.1
  cp xsp.1 fastcgi-mono-server.1
  make[1]: Leaving directory `/root/src/xsp-2.4.2/man'
  Making all in src
  make[1]: Entering directory `/root/src/xsp-2.4.2/src'
  Making all in Mono.WebServer
  make[2]: Entering directory `/root/src/xsp-2.4.2/src/Mono.WebServer'
  /usr/bin/mcs -debug+ -debug:full -nologo -unsafe -nowarn:618 -doc:../../docs/Mono.WebServer.xml -r:System.Web.dll -r:Mono.Security.dll /target:library /out:Mono.WebServer.dll ./ApplicationServer.cs ./BaseApplicationHost.cs ./BaseRequestBroker.cs ./IApplicationHost.cs ./InitialWorkerRequest.cs ./IWebSource.cs ./LingeringNetworkStream.cs ./MonoWorkerRequest.cs ./XSPApplicationHost.cs ./XSPWorkerRequest.cs ./XSPRequestBroker.cs ./XSPWebSource.cs ./XSPWorker.cs ./HttpErrors.cs ./Paths.cs ./VPathToHost.cs ./Tracing.cs ./SearchPattern.cs ../../src/Mono.WebServer/AssemblyInfo.cs
  ./Paths.cs(50) error CS0106: the modifier static is not valid for this item
  Compilation failed: 1 error(s), 0 warnings
  make[2]: *** [Mono.WebServer.dll] Error 1
  make[2]: Leaving directory `/root/src/xsp-2.4.2/src/Mono.WebServer'
  make[1]: *** [all-recursive] Error 1
  make[1]: Leaving directory `/root/src/xsp-2.4.2/src'
  make: *** [all-recursive] Error 1

  I've not seen anyone else out there have exactly this problem; does anyone know what might be causing it? I've tried to configure both like this
  ./configure --with-prefix=/usr

  and like this
  ./configure --with-prefix=/usr/lib/mono

  ...and get the same error each time. 

  Thanks for any ideas!

  View this message in context: Mono XSP compile error
  Sent from the Mono - General mailing list archive at Nabble.com.


  Mono-list maillist  -  Mono-list at lists.ximian.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-list/attachments/20090722/f72d1059/attachment-0001.html 

More information about the Mono-list mailing list